Streaming live at 10am (PST)

LinkedIn is not recognizing the set og image

Hi, I’m having trouble with LinkedIn scraping the set og image on various pages. On a few pages it’s OK, including our blog pages, but on others (Careers and Forecast for example) it either scrapes the wrong image or doesn’t find an image at all, despite the fact that I’ve specifically set an og image for each page. I’ve tried adding custom code for the header, per LinkedIn’s Post Inspector suggestion, and that doesn’t work either.

Here’s what is set in Webflow:

And here’s what LinkedIn is returning (from Post Inspector; but it’s the same on the site)
Screen Shot 2020-08-05 at 9.30.08 AM

Thanks for the help!

1 Like

This is happening to me as well and it’s driving me crazy.

I think something is up, as I’ve repeatedly saved and published changes to my homepage copy and changes aren’t getting pushed through.

OG image placement:


What LinkedIn is showing:
linkedin OG

I’ve mucked around with meta tags and hard refreshes to no avail.

OK well it’s nice to know it’s not only me!

Same issue here. I went pretty in depth troubleshooting. It Looked to me like Webflow doesn’t add the meta tags to the web page in the format that Linkedin wants.

How do we escalate this to the Webflow support team?

I think something is up Jenn, as I can’t log a support ticket either and posted about that too.

For both - my workaround was recording a snippet of the page so it popped in LI feed, but I don’t think it worked as well.

Ok. Well, for the post thing, when posting on LinkedIn they do allow you to change the link image when you create the post. So that’s a fine workaround, but it would be nice if we didn’t have to do it. :wink:

1 Like

Hi. I have shared from my website to LinkedIn for months not, without any issues. All posts are shared with the image I provide in the Open Graph settings.

Now, all of a sudden, LinkedIn can`t find the image when I try to share it there. It works well on Facebook and Twitter, only LinkedIn that seems to not find the image:

Checking the source code I see the metadata properties are there:

Did anyone encounter the same issue?


MOD EDIT: This was merged from a separate thread.

Is this a new page you’re sharing, or one that you shared previously, before having opengraph details? If it’s possible to re-scrape a url as you can with Facebook it may be worth trying that first.

Linkedin caches the url for 7 days, so try adding the url again but add ?latest to it.

So if your link was, try it as

This ? starts a new query string so Linkedin should look for the new data, what as appended after the ? shouldn’t matter.

Let me know how you get on.

@magicmark you seen this one?

Thanks @jasondark, I’ve merged the topics as I hadn’t seen this one :+1:

Hi, the webpage is not new, and I have been posting to LinkedIn successfully many times. It just happened now, and I haven’t changed anything.

Also, I tried to add a ? after the URL and there was no difference.

I see others are having the same issue. Clearly linkedIn has some issued finding the Meta for the image.



I have the same issue with one of the old accounts but not with others. The image appears on Facebook and Twitter but not on LinkedIn

Hey @magicmark, thanks a lot for helping.

I have a similar issue with the meta description not showing properly on LinkedIn. When adding “?latest” it kind of work. But would that mean, I cannot send my real URL? How could I fix this issue properly? LinkedIn sent me this help page but my SEO set up on Webflow are already updated correctly:

Thanks for the support!

I’m facing the same issue with my LinkedIn Posts.

I’ve been experiencing the same issue. I came across, which has solved the problem for me.

Make sure you have prefix=" og : in your tag, when you have iframe(s), make sure which page is calling the share function. Hope it will help. Does your code look like this? Adding a garbage parameter at the end of my link, helped me force linkedin to get og : image again.

Same issue here for months. @dgordon @indianembassyrome Is there some specific custom code we can add to get this to work? If so, can you please paste the exact code you used? Inside tag, or before tag? Thanks!

@drew-flps I didn’t use any custom code. I just added content to the Open Graph settings and then ran the URL through Post Inspector