Open Graph Image Not Loading on LinkedIn

Hello! In my CMS Blog Page Template settings, it is showing that the open graph image should load; however it is not sharing when I share the blog on LinkedIn. You can see it won’t load in this link: Post Inspector

Any idea why that’s happening?

Here is my site Read-Only: Webflow - New

Is your image artwork by chance WEBP?
Linkedin doesn’t support that yet.

Hey Michael and Ayah, I’ve been having the same trouble with this except just for static pages (not CMS collection pages).

Some of my pages are not previewing the Open Graph images that other social platforms are. I know this has been an ongoing issue for other users. One solution I’ve found is the Post Inspector from LinkedIn, but when I try to use the Post Inspector all of my links come back with an error message (even the pages that are showing up with correct previews). I wonder if this is an issue with my link and not LinkedIn’s? The inspector is working when I use the domain. Is there a way to double check that everything is sound and working correctly from my custom domain end?

I’ve tried adding the meta property tag to the body of my page, and adding “?random” to the end of the Open Graph image URL, but these have not worked. The pages I’m having trouble with on LinkedIn specifically are Careers and Customer Success. And the images I’m using are jpegs or pngs, not webp’s.

Here is my read-only link: Webflow - SOLARCYCLE

Hey Rachel what are your URLs for both your staged site and your primary public site?

Hey Michael, thank you for responding to this but this actually fixed itself? I think LinkedIn’s cache just need time to catch up…I appreciate the quick support though!