Streaming live at 10am (PST)

Zapier + Webflow doesn't work because of "slug" field

Hi, I have a problem to integrate my Webflow with Zapier to send form data into CMS.
There is a problem with “slug” field, because this option is a required field.

I use Webflow tutorial to do it correctly: https://www.youtube.com/watch?v=I8zl6qLbm3k (10-18 min) and everything seems well-done.
I’ve just realized that slug field is required now and I can’t delete it.

I’ve attached a screenshot from Zapier. @PixelGeek or @brryant do you have any idea how to fix it?
Thanks in advance!

Why not just provide a dummy slug field? Create a randomized value to it or whatever… It doesn’t need to be meaningful to you , but slugs are a core part of collection pages, even if you don’t plan on having them.

A nice alternative I’ve found is Basin https://usebasin.com
I’m using on exported and hosted sites. This is the post I followed for integration and it was pretty easy and used Webflow form tools.

Of course it’s one more thing to sign up for :frowning: First from is free though and good for testing before purchasing.

The problem was with a “Select Field” + “Collection Field” from CMS. Is there any solution to integrate them both?

Thanks!

Hi … did u find any solutions for the “slug” field ?

I also get problems with the slug, but sometimes i don’t.
I’ve reformatted it with Zapier with “url-encode” and also “lowercase” but on some items it just doesn’t work.

What is wrong? What are the exact requirements for the slug?

I was running into this issue and the Webflow support was able to provide a solution. Essentially, you need to change the name of the slug field to just “Slug” for the particular collection you are including in the Zap. The Webflow team made a video to explain:

1 Like