Streaming live at 10am (PST)

Problem with Zapier "The app returned "ValidationError: Validation Failure."

Hi Webflowers,

I have problem with a Zapier integration.
I want to publish an item from a Youtube channel when there is a new video on this YT channel.
But when I’m trying to do that I have this message:
“The item could not be sent to Webflow.
The app returned “ValidationError: Validation Failure”.”

image|690x116

Here is all the fields of my collection (video):

Do you know how I can resolve that?

Thanks,

Here is my site Read-Only: https://preview.webflow.com/preview/notion-everything?utm_medium=preview_link&utm_source=designer&utm_content=notion-everything&preview=f1ecdc4880bf4e72b4602806522189c8&mode=preview

@valentin_geffroy Did you resolve this? I am having the same error and Zapier doesn’t even tell you which field it has a problem with

I’ve found this to be usually due to a require field not being passed.

In the screenshot above the “Name” and “Slug” fields are required so make sure you are sending them from Zapier.

Further, the “Archive” and “Draft” fields within Zapier are required as well, make sure you’ve added a value for them.

@ycee can you detail your specific issue a bit more? Screenshots?

I have found that the cms field name sometimes doesn’t change when it’s updated, so zapier would then try to send information to webflow to a place that doesn’t exist. Try using postman to find the actual api info and use that instead

Yes I did!
As @ChrisDrit said you need to check your required fields.
Also make sure it’s the same type field you’re receiving and sending from Zapier.

1 Like

Oh yes guys finally got it working for me too.

Something interesting, the Slug is required in the CMS, I am not sending it via Zapier though as it’s not a use case for me (no separate page links per CMS item)

And it works just fine interestingly.

I’m also struggling with this. I’m trying to pull an event from Eventbrite into Webflow via Zapier. I keep getting an error which I suspect is slug-related.

I’m not a developer by any stretch of the word, just a mere graphic designer – any help greatly appreciated!

Here’s my Webflow link:Webflow - APS

Can you post the error message that Zapier is spitting out?

The error message isn’t particularly definitive, I’m afraid.

Yea, that’s the typical error. Did you run through the solutions suggested in this thread? They would most likely address your problem.

Hi Chris, yeah I’ve tried to replicate what’s above, but I don’t seem to be able to find anything in Zapier to populate the required slug field. Any idea what I should be looking for?

That error means that the Webflow CMS is expecting a field to have a value when you create an item, and it does not. You have a slew of “empty fields” listed in your screenshot. Have simply gone in and manually entered dummy values for each and re-run the zap?

Interesting. Although the fields were not required, the error message is different now. The error I’m getting now is based on an incorrect value for the “book now” field in my CMS - that makes sense.

1 Like

Yep. That approach will usually help to understand any deeper issues you may have.

Thanks for your help Chris. I just pinged you an email.

1 Like

HI, @ChrisDrit I did what you suggested and nothing. I can’t believe Webflow or Zapier don’t have a solution for this. I’ve been using the platform for years and it seems that nobody has a solution to avoid the “ValidationError: Validation Failure”.

1 Like

@carlos94587 the issue is that everyones specific error is different. So there is no universal solution that says “do this and it’ll fix your problem” unfortunately :rage:

To work around this successfully you have to understand what that error is “trying” to say, since, well… the message is not descriptive in any sort of helpful way (Zapier should work harder at providing more ‘clues’ for individual use-cases).

What’s it’s trying to say is that a field you are sending to the CMS is wrong.

Maybe the field in the CMS is required and you’re sending something blank. Maybe the field no longer exists. Maybe the field expects a number and not a string of data. Maybe you’ve updated the CMS (and may not even remember) and now Zapier is out sync. Maybe… <insert 100 other possible reasons why>.

They key to solving it is to chip away, one by one, at all the possibilities until you start to get some clarity as to what the true problem is.

That was the basic exercise that @BrownHFX and I went through (over email).

I recommended for him to do “something” that then in turn showed what the true problem was.

If you have the time, and willingness - I know it’s super frustrating and it feels like you shouldn’t have to waste your time on this when you pay for services. But, this is the reality of us pushing beyond the limits, to make awesome stuff :sunglasses:

If you have the time, and willingness…look at the problem from this perspective. Try adjusting Zapier. Try refreshing the fields in Zapier (it connects to your CMS to fetch the most recent fields). Create another Zapier zap and only attempt this with 1 field to get it to work. When it does, add a 2nd field. Do this one-by-one until it breaks.

One thing I like to do, but is super technical, is to ping the Webflow CMS directly as if I were Zapier. How? If you look at the Webflow CMS API docs, on the right hand side you’ll see a curl statement if you’ve selected shell (versus javascript) for the example request.

Figure out how to use curl through some Googling if you don’t already know…try to make a curl call directly into your CMS with the fields and values Zapier is sending. Go back to my previous statement and instead of doing all of them, start with just one field and one value. Get that to work. Add another, and so on…

Major PITA, I know… but if you take the time to go through this process, chances are you’ll come out learning a ton that will help you in the future, and have a high likelihood of solving your problem today.

Now that was a long arse post! :rofl: Hopefully you can pull 1 or 2 tidbits out of it that’ll help you!

1 Like

One thing i’ve noticed is that if you’re using the “create live item” action then if you’ve changed your CMS and haven’t published the changes then the fields that zapier is expecting are different on the live site than the ones you are sending over (even if you hit “refresh fields”).

Hope that helps someone!

1 Like