Getting fields.slug’ invalid input error when using Google Sheets to Webflow CMS

I’ve been fighting with the Webflow API for the last couple of days to try and get it to accept a slug when pushing data from Google Sheets to Webflow CMS using Zapier.

Weirdly it was working a couple of times yesterday when I tried and then it just stopped working. I haven’t been able to get it to work all of today.

No matter what I try to enter in the ‘slug’ field in Zapier, I keep getting the error:

“‘fields.slug’ invalid input”.

This is what I’ve tried…

Properly formatted slug:

Screenshot 2024-01-19 110604

Slug without spaces:

Screenshot 2024-01-19 110628

Empty slug field:

(this caused a validation error because the slug is a required field)

Screenshot 2024-01-19 111123

Using the title as the slug:

Screenshot 2024-01-19 112629

Manually entering the slug:

Screenshot 2024-01-19 111453

I noticed in Zapier the ‘slug’ field in the test had a lowercase ‘s’:

Screenshot 2024-01-19 112800

So I changed the slug label in the Webflow CMS to also have a lowercase ‘s’:

It made no difference :upside_down_face:

I’m not the first person to run into this problem. People are facing the same problem with passing the slug value from Google Sheets to Webflow for the last few years.

All the suggestions in those earlier threads have not worked.

I feel like I’ve tried every permutation I can to try and get the slug field passed into WebFlow CMS but it’s just not accepting it.

Is WebFlow broken or is Zapier broken?

I certainly feel broken after trying to figure this out for the last couple of days.