Why is my form not submitting when I used form element? When I push submit, it does nothing

I used the form element and submit button, but when you push submit, it does nothing. Would appreciate any tips on this. Probably so simple and I’m just not seeing it.

Thank you so much!

Read only : Webflow - Diego

Here is my site Read-Only: [LINK]1
(how to share your site Read-Only link)

You replaced your Submit Button with a regular Button.
You need to add that back.


hey! I added a submit button and it still doesn’t work :frowning:

It needs to be published obviously, I can’t find a published site anywhere to check for console errors.

You might also check to make certain your form is not linked to a missing Logic flow; readonly links don’t know that.

Other than that, you might try with Webflow Support.

thank you! My site is published - diegochigago.com

Webflow support sucks so bad, I’ve written them three times in over a week and they never respond. Thank you for your time

Looks like it’s working now;

Weird, I’ve always had fantastic experiences with Webflow’s support team. You generally just have to use the support page and choose the right category. Hope they’re doing ok.

1 Like

Thank you! It’s so weird. Last year they were so responsive - now it’s just terrible.

For the form, i have no idea what happened, but i just ended up rebuilding it from scratch and it worked. Thank you!