Streaming live at 10am (PST)

Form submissions not Working . Can't press the submission button

Here is the shared URL:https://preview.webflow.com/preview/xlargetesting?utm_medium=preview_link&utm_source=dashboard&utm_content=xlargetesting&preview=9793f3643c9f7be113454c2316d41c71&mode=preview

I having working for this web for a while, and unlucky I got stuck in the Form submission, after filling the form I can’t press the submission button, I need help very bad…

Thx for any tips and way to solve this problem!!! (Sorry for bad English and being a noob on webFlow)

Big Thanks!

Hi @ocram_sheep,

The reason your form doesn’t validate is that you have a redirect url in the form settings.

image

If you have no intention of using a form validation page, you can just empty that field and it should work.

1 Like

I tried , and still nothing happened after pressing the button…

@ocram_sheep - can you share the published site link?

@ocram_sheep - you have hidden fields that are required that are preventing the form submission:

image

1 Like

OMG big thx!! I know it looks stupid, but you save my life!

No problem, glad I could help. :webflow_heart:

Hi there!

I am having the exact same problem in my multi-step form, tried everything but it doesn’t seem to work :frowning: Can someone help me with this?

Here’s my read-only link: Webflow - Allservices4u

Thanks!

@zivrotems - I just tested your form and the submission works. Can you point out more specifically what is wrong?

Managed to make it work, thank you!

Hi @sam-g browsed through this thread and i seem to have a similar problem. Tried everything but does not work. My one page site is multilingual so english form works just fine, and arabic for some reason does not at all, there is no reaction when pressing the “Submit button”. Here is the link for preview: Webflow - ADQ Omniyat

please can you assist me on this?

I tried , and still nothing happened after pressing the button…

192.168.100.1 192.168.1.1

@navidon9 - just submitted both versions and it seemed to work fine for me.

Hi @sam-g thank you for taking the time to assist me with this. I seemed to have solved the problem by reverting to the previous state of the form, which was to restore the hidden selection box and remove the simple text box from the form. Previously I had just hidden the selection box and inserted in its place a text box. That seemed to block the system. But still not sure why.

Thank you

Hello @sam-g. I read through this thread but couldn’t find a way to solve the problem that I have. The form works fine with Safari… But as soon as somebody uses Chrome or Firefox and tries to send it, it is not possible to press the submit button. Any idea where that comes from? Here you find a read-only link to my project.
Thank you for you help! :slight_smile:

@AndreasHaenggi - Which form are you having trouble with? It looks like you have a registration form and a newsletter form. I tested on Chrome and the registration form worked, the newsletter seems to be the one having issues, but just want to confirm.

Thanks,

Sam

Hi @sam-g Thank you so much for your super fast reply!
Yes there are two forms. I don’t have problems with the newsletter (purple) form (Safari, Chrome, Firefox… works for me) but for the registration form (red). If I go to the page via Chrome or Firefox and type in all the necessary details into the form and try to send it off it doesn’t let me click the submit button («weg damit!»). Well… at least I do not get a confirmation message below.
Thank you!
Andreas

Hi @sam-g form submission button is not working. I tried all things according but still couldn’t found the solution. please help me out about this. thankyou!

@Codernsquare - can you provide your read-only site link, published site link and a description of which specific form (if there are more than one on your site) is causing the issue?