Streaming live at 10am (PST)

Updating global color swatches has no effect on published sites

I noticed the problem when the new style panel was introduced. I think it has something to do with updating global swatches created with the old style panel. For example, I was able to switch to the old panel, update the swatch, and switch back

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @DuncanHamra, thanks for the report about the update of the global swatch using the new style panel. I was checking on the site and tried to update a swatch and did not have any trouble doing so.

Could you help to share the exact element and class and page where you are unable to change the swatch?

Thanks in advance.

1 Like

Hi Dave! That read-only link won’t do us much good here since the problem is only visible on the published site. The designer updates fine, but the changes don’t carry over to the published site.

If you open a project using global swatches that you created with style panel 1.0, change the swatch color, and then publish you should see what I’m talking about. :+1:

Here’s a video to further explain

Hi @DuncanHamra, thanks, can you also help to share the link to the published url where the issue with the swatch is happening? Thanks in advance.

1 Like

Hi @DuncanHamra, thanks for the video as always, I made a quick video to show what I am seeing:


Let me know if you get something different, the green color actually did not appear to be a global swatch on my end, but after creating a global swatch I was able to save and modify the color.

Update: I was able to observe the behavior with existing swatches, but not new ones. I am continuing to investigate this further, the moment I have more info, I will post an update.

1 Like

This sounds awfully similar to this my topic actually. I wonder if the fix didn’t catch every possible scenario for the bug.


Hi @dram, yes, this looks related thanks for the reference, this is being checked and as soon as there is more info, I will post an update.

1 Like

Thank you :grin:

I appreciate your help

@DuncanHamra thanks a ton for posting this! Can you please let me know if the following workaround saves your global swatch style change? I noticed that if a save event (which happens every 20 actions or if you press CMD + S) doesn’t occur that I ran into that on my end.

  1. Edit the global swatch color
  2. Press CMD + S or CTRL + S on Windows to save your site
  3. Publish your site

Please let me know if this solves the problem in the mean time as a workaround.

If not, I’m happy to help further!

@DuncanHamra After testing this a bit, I think it might be due to that old instance of the color swatch. Can you try to create a new global swatch and retest to see if it’s happening with the new swatch you created?

I’m having the same issue and this didn’t seem to help me.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.