Saved colors doesn't apply

Hello world,

I have experienced this thing a few times. I created a website from scratch and assigned some colors to my palette. A couple of them I’ve called something like “CTA” and “CTA hover”. When I’ve duplicated my project and adjusted it to my needs. When ever I change my palette colors to a new color, it shows up in the editor, but when I publish my website, some of these colors haven’t got updated. It’s like it forgets my adjustments to these colors. What do I do wrong?
You can see my published website here:
And in my preview link, you can see the colors on the text “Fleksibel bogholderi” is green on the published site and blue in the editor. Also the buttons border in the bottom of the frontpage, and the dropdown menu links in the navigation.

Edit: I know from earlier that I can adjust the color to another one, and save it, and adjust it back to the same value as before, and then it will work. But it won’t work without doing this. So it has to be some kind of bug.


Here is my site Read-Only:

That is weird !
Are you sure you publish the changes to this address? not mixing with 2 different projects?

Yes, the site is a project, where I haven’t attached domain yet.

You mentioned this:

Both projects are alive? can you share the published site and the read only link to the original project?

Now I tried taking the border color of the button in the bottom of the frontpage, and select another color from my palette. If I publish it does update to the new color. If I then select the CTA color which is a darker blue-ish tone, it goes straight back to the blue color which was set prior to duplicating the project. I do not even have this color in my palette anymore, but it still shows it on the published website.

This is the project I cloned from:
And the website looks like this:

This is my new project, cloned from the above:

ok, seems like a bug…
@Brando, @Waldo, @PixelGeek for the rescue

1 Like

Does it look like this problem?

It could be related to it, but I haven’t verified it. But yeah, since I changed the swatch color to another one, without removing the already existing one. So it’s very plausible that this is the case.

OK, Aviv already called for Brando anyway so let him answer this.

1 Like

Hey, @JacobMunch!

Thanks so much for reporting this issue. I am doing some investigating now to see if it’s related to the earlier issue mentioned or whether this might be something new. I’ll post back here as soon as I know more!


Ok, @JacobMunch! I did some investigating and this indeed looks like the same issue.

I made a copy of your project and did the following:

  • Edited the global color swatch at issue
  • Switched it’s value to a random color
  • Pressed CMD + S (CTRL + S on Windows)
  • Edited the swatch again and changed it back to the desired color
  • Pressed CMD + S (CTRL + S on Windows)
  • Republished the site

Once I did that everything worked as expected. I’m notifying the team of the issue and we’ll let you know here as soon as we have more information!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.