Streaming live at 10am (PST)

Unable to adjust div block dimensions in grid

I am new to Webflow(literally began today)

I am taking the grid approach to create my site. as I am adding div blocks I was initially able to adjust the div blocks to span over multiple FRs horizontal and vertically in the grid(at this time the div block would show red when I would hover over them and I could adjust). I am not sure what I did but I am no longer able to adjust the div blocks and when I hover over a div block it shows a blue color. But the entire page has the red outline around it. please see attached screen shots

01%20PM

My question is what do I need to do to be able to go back to adjust div blocks to span vertically and horizontally.

hope I explained this clearly and thanks in advance for any help, sure its something so novice.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hmm, I couldn’t get your read-only link to work so I can’t say for sure but this is probably because you aren’t selection the top div. So if you’ve got a div in a div in one grid, you need to select the parent div to get those red lines that allow you to move the div around. Let us know if that helped or that wasn’t the issue.

thanks for your reply Sarah. I closed the application and re-opened it. once I clicked on the text div block (div in side of a div on grid) the red lines came back with the option for me to adjust the sizing. I then went to the navigator and saw I have selected the text div at the very bottom. so It might be a different solution that what you explained. hopefully you can see this attached screen shot!

whatever works :wink: . Glad it’s working again :+1:

actually It has occurred. again. all div block and sections are blue and I cannot resize them. same issue again.

Please share a Read Only link to your project.

please see read only link below. It is the “product page”

https://preview.webflow.com/preview/supermrktblank?utm_source=supermrktblank&preview=b65e2e0b04677fefa82203c8e2234954

I am very confused about what you are trying to achieve with a grid layout.

CloudApp

I would recommend that you just create a simple sketch / mockup of what you want this page to look like. At least then I could give you feedback on possible approaches.

It looks like you might benefit from running through some of the courses available on webflow’s university if you have not done so already.

I figured grid would be ideal for what I am trying to accomplish with positioning of images but maybe you will show me I was wrong! Here are some Mocs, this is the specific product page and the multi product page

31%20PM 50%20PM

Resend, I have posted the mockup. Please let me know you advise best approach to create with :smile:

Having same problem, cant resize div elements inside my grid. It wasn’t a problem a couple of weeks ago but seems theres been an upgrade and this is a bug.

I am also having the same problem. When I click on an item inside the grid, the red line showing the boundary of the item is the whole grid and it has been messing up all of my content in tablet and mobile view.
Does anyone have any solution? Thank you so much!

Here is the read only link: https://preview.webflow.com/preview/croatia-2019?utm_medium=preview_link&utm_source=dashboard&utm_content=croatia-2019&preview=2e2893be7e81298fd2d0a85f0f0efc83&mode=preview

It is “Dubrovnik 2019” page

Thank you so much

I too am stuck not being able to span columns and rows in grid. I am just trying to figure things out before embarking on a project so nothing to show. In fact am following along with pixelGeek on youtube. I do not get the orange outline and handles. Is there something I/we are missing?

OK ignore seems changing browser works which is add as it worked fine in opera previously. Works in Chrome and Tor Browser so all is good. Sorry to trouble you all.

@aktiosphoto hi there! Glad you figured out the issue. Yes, the webflow designer doesn’t always play nicely yet with browsers other than chrome, it can cause unexpected issues :slight_smile: .

Hi there, I have the same exact problem of @bebble241
I added a section to the body
I added a grid
I am adding div blocks
I was initially able to adjust the div blocks to span over multiple FRs horizontal and vertically in the grid (at this time the div block would show red when I would hover over them and I could adjust)
BUT now I am no longer able to adjust the div blocks they show inside the grid with a grey contour while the grid get the blue contour with the little handle to resize …

The same happens when I start with a collection list and then I apply the grid, the Div blocks are not “resizable”

I attach the read only link but there is nothing there,
just two PORTFOLIO SECTION with inside the grids
and inside each grid Div block “un-resizable”

Thank you very much for any help!

https://preview.webflow.com/preview/tusj?utm_medium=preview_link&utm_source=dashboard&utm_content=tusj&preview=2426a11cee391a506d750873be99a321&mode=preview

HURRA !
SOLVED IT!

I logged off Chrome, I logged back in and update the browser
and now IT WORKS !

Sorry for the trouble nice people…
but maybe someone can find this experience useful :slight_smile: :wink:

1 Like

I am trying to expand the div box to span over a few rows and columns in grid (as everyone above) and am not getting a little box at the bottom of the div box to do so. The browser I am using is Chrome 79 so I am going to see if I can get Chrome 78 and see if that helps.

***UPDATE Google doesn’t allow downloads of old versions. I’ve uninstalled and reinstalled Google 79 but still can’t resize the Div Box in the Grid which I was going to use to pop photos in for my portfolio. (Similar to what Brian Haferkamp’s Youtube video from 24 Oct 18 ‘Create a Tiled Photo Gallery in Webflow’.)

Any help?
https://preview.webflow.com/preview/know-your-garden?utm_medium=preview_link&utm_source=dashboard&utm_content=know-your-garden&preview=e3e2bea1234a2d311f631ddfa48ee54b&mode=preview

Hi @rmethom,

When in your project are you having an issue? Please be specific on which page and section of the page the error is occurring?

Best Regards,
~ Brandon

Hi Brandon,
It’s on the Portfolio page, in the body which has a grid on it. I’ve dropped a DivBox into the grid as well as a container and photo but neither can I adjust even if I try to switch the DivBox to Flexbox.

Thanks for your help,

Rebecca