Publishing the website doesn't update changes

Hi, I’m stock with an old version of my website:

-> on the webflow domain changes are updating OK

-> on the linked domain changes are NOT updated !

I tried to unpublish and publish again on the linked domain, but it didn’t work.

This is my first website with Webflow and I advertised my client it would be very easy to push updates… :neutral_face:

Thanks, if anyone can help !

1 Like

Hi, it’s probably just a browser caching issue. Try hard refreshing your browser window or view in an alternate browser. I just viewed it and looks correct on the live domain.

Thanks, I see it alright now.

What else can you do, when removing the cache doesn’t work?

Anyone have an answer? I checked 5 different browsers on 3 different machines. Publishing NOT working. In Editor Publish button greyed out. In Designer, publishing not changing content on site. Could it be a Webflow Server cache?

  1. Editor Publish Button greyed out for both my client AND me
  2. Designer view publishing doesn’t change web
  3. DNS didn’t change
  4. Browser cache NOT the issue
1 Like

I have the same problem now. I published a page to the Webflow subdomain and custom domain. And content is updated only at the version with the Webflow subdomain. Not my custom domain.

Tried on different Chrome profiles and I can still see the 1 hour old version on my custom domain website.

After almost 24 hours the website was still not updated. So I tried to publish it only to my custom domain. And suddenly it started work. Sort of buggy product.

I would expect a more stable product from a multibillion company…

Hm … I also had the same error once and it kinda aswell fixed itself. Do you know any reason it could be?

@Jindrich_Bartek - Make sure you don’t have caching between your browser and Webflow hosting. If you want assistance debugging this issue then please provide URL’s and publish time / date info for each.

Hello - also having the same issue!

how can one remove caching between your browser and webflow hosting?