Publishing for hours with no changes reflecting


I am having an issue with publishing changes on a site. I noticed that it says ‘Published Successfully’ while also stating “Published a day ago” and not minutes ago if the changes were published indeed.

I have tried checking the Designer in incognito mode but it still does not work. I have tried unpublishing the staging site ( to publish again, but it does not work either.

I have attached a screenshot, as well as my Read-only Link for your reference

What do I do to make these changes on the domain as soon as possible?

Thank you for your help.

Read- only Link - Webflow - Urgent 2K

Site Link - (I unpublished and it now it says Page not Found). Please help

Hi Ibilola,
What is your Webflow settings Timezone?
Try changing it to the correct timezone you are in and probably disable any VPNs if you have any.
You can also try using another ISP/Network to see if the error still persists.

If all these don’t work, you can try duplicating the project and publishing it again.

Thanks a bunch Ogoluwa, I tried all of these and it didn’t work sadly.
I have reached out to Webflow support though

Had this problem all day yesterday. Not sure Webflow has made any public comments about it, but it was definitely a problem.

Feels comforting to know it’s not just me :bowing_woman:. Were you able to find a solution to it though?

I didn’t encounter this issue but since @Jamie_Rodriguez also encountered this, then it is likely a general issue.
Try reaching out to Webflow Support to solve this.
Maybe an update they made at a particular time affected some selected sites.

I have the same issue currently and there is another thread with others that have the same issue. Has anyone heard from Webflow about it?

1 Like

I reached out to Webflow support and it seems to be an issue that they are taking seriously right now.

I guess we just have to be patient :frowning:

There are no current publishing issues listed at so it is hard to say what is going on as to whether this is an isolated or a widespread issue. Can you share what response you received (with identifying content removed)?

Thanks Jeff. The solution they advised has finally worked.

I have attached an image of a cropped email. I had to unlink component instances on specific utility pages, not sure why that worked in the end.