Streaming live at 10am (PST)

About Zapier's integration with Webflow (The app returned "ValidationError: Provided ID is invalid".)

To whom it may concern

I have a question about Zapier’s integration with Webflow.
I am currently trying to input data into Webflow using Webhook.
On the other hand, I tried to integrate as you can see in the attached image, but I get the following error message and I can’t get the integration to work.
I would appreciate it if you could explain the reason for this message and how to solve the problem.

The app returned “ValidationError: Provided ID is invalid”.

I usually get this when a required Webflow CMS field is missing. So make sure all the required fields in your CMS collection are getting passed in from here. Report back if that was it or not the case…

I have the same error with Zapier Integration. Was a solution found here?

Hi @Love_Nocode , have you found the reason behind the error?

Hi @ChrisDrit, could you please specify where CMS fields could be missing? I’m running into the same error and can’t figure out what’s going wrong. Many thanks in advance for your help

Hi @mjrvanschaik :wave:

It’s a big question to answer for each specific case :slightly_smiling_face:

But generally speaking you can get Zapier “out of sync” with your Webflow CMS. You may change, update, remove, etc… fields in your Webflow CMS that Zapier previously saw (before you made those changes) and expects to exist. Zapier is making a call into the Webflow API and it’s asking for a field that may not be there. That’s just one of many scenarios that could trigger this.