Live item creation via Zapier works randomly


I run into a weird issue that appeared suddenly. Here’s what I am doing with webflow, zapier and memberstack:

  1. I have a Webflow form linked to Memberstack to create users’ accounts
  2. I create a live collection item in Zapier in order to have user pages later
  3. I then create a second live collection item (in another collection) to create private user pages

I keep having the following error at the second OR third step.
The app returned “ValidationError: Validation Failure”. This usually happens when your Zap is missing a required field or a field value isn’t in a recognized format.
At some point I had this error “ValidationError: Provided ID is invalid” but I can’t find it again (it was a bit hidden in Zapier)

I tried

  • passing really the bare minimal (name and slug)
  • just typing test value in Zapier
  • relinking Webflow to Zapier
  • creating a new Zap
  • re-publish numerous times

Here’s what’s puzzling me:

  • It worked for days but suddenly stopped at noon.
  • Sometimes it just works, with the exact same data, I can’t get why.
  • I tried posting on the same collections via Postman and it works everytime

Any help would be really welcome :sweat_smile:


1 Like

A small update after more investigation.

I created new collections (same model) and it worked fine again.
For my tests, I delete the live items everytime.
The second time I use the same data, the API call fails.

It looks like I can’t re-use the names/slugs I have already used (eventhough I deleted the live items).

Anyone had the same problem?

Same problem and it’s driving me nuts

1 Like

you sort this? I had this issue and you still have to publish after delete.

No :frowning_face:

It’s in production now but I had to be creative with my tests

Hi all, I’m currently encountering the exact same issue, and have been troubleshooting for the past 2.5 FULL days. Was working fine, then stopped. Have done all the same steps as you @francoischay. I’m losing my mind. And to specify I am running into the issue with posting to CMS collection.

Same here.

Really disappointed. I jumped on the platform recently as I was hooked by its power. I paid today a full year to be able to leverage APIs and now I’m stuck. I thought I was doing something wrong but it looks like this problem is all over the places and the years, back in 2017 for what I’ve seen on the web.

Please help us guys…

Zapier customer support told me it’s a Webflow issue. Multi-reference fields are not supported. Supposedly Webflow sends the information incorrectly.

This is really annoying and a game stopper. Please fix this!!!

Also jumped in here to add that I was also having the same issue. I ended up creating a new collection which was a work around.

Contrary to what iane added, multi-reference fields work but I use Zapier’s webhooks to post multi-reference fields manually.

I am now also experiencing this exact issue under the same circumstances. Has been working for weeks. Was doing some testing. Initially got that “Provided ID” error but now only get the “Validation Failure”

Dang…I was meant to hit production this week

Figured out why it was happening to me. Collection ID’s changed when I reverted to a previous backup, causing validation errors due to the ID being used being no longer correct.

1 Like

I don’t even juse multi-ref things, and also i only want to add a new item (and afterwards get the webflow ID to add to a Google Sheet.

Was working yesterday, now i also get the Validation errors.
Might/could this be a rate thing ? (you can only access /read/write into the webflow database a certain amount of times (i read there is a 60 operations per minute thing, but it can also deplete if you constantly use this for hours - or many more per minute…)

This is not good for Webflow and/or Zapier.
Once setup and working, these things should never break like this.

Argh isn’t that the worst, I’m going through that right now — changing all of my CID’s and ID’s and then retesting all zaps so they function again. About 8 hours of work all because of an innocent click of a button (publishing a backup). :skull:

I’m having the same exact issue. I add extra fields that absolutely should work, and after verifying everything was correct I still get the validation error.

The Webflow CMS integrated with Zapier was a major deciding factor on why I migrated away from Wordpress and Wix, so I’d really appreciate some addressing by the Webflow developers.

Has anyone figured this out? My Zap setup has worked for months, and suddenly stopped working this morning.

For those who have dealt with this, did it resolve on its own? Was the only solution to create a workaround?

Any insights greatly appreciated

Only thing that worked for me was start from scratch with my zap :confused:

@allenwixted Just checking in to see if your zap is still stable after starting it from scratch?

Anyone else have other solutions?

i also started over again, and then it worked. and then i tried to add something new = same again.


I am having the same issue… but recreating the zap didn’t work.
Same issue happens for Zapier actions “Create Live Item in Webflow” or “Create Item in Webflow”

Did anyone find a way to make it work ?