Streaming live at 10am (PST)

Problem with Webflow Zapier Integration

i’m having troubles on intergrating google spreadsheet row to create new collection item.
When i catch my data from spreadsheet via zapier, i select webflow option and choose my project and my collection. then i fill the data exactly it appears on the collection and i when i’m testing my zap i got this error:The app returned “ValidationError: Validation Failure”.

i tried several times to check if i have missmatched some required data but nothing helps.
Anyone know how to solve it?


I just tried to reproduce this issue of sheets data to webflow new item in CMS but it worked fine for me.

You should use False for both archieve and draft. And also make sure your site is published and not in draft stage. It should work.

Yes I’ve been having this trouble too (using Airtable instead of Google Sheets) and it seems to be a widespread blocker for many Webflowers.

Followed multiple tutorials which step it out perfectly such as the one by @MackenzieChild but still seem to receive an error. Any ideas guys? @PixelGeek might be across this too

1 Like

Hi Frazer, are you trying to create a new live item in the CMS with a zap from Airtable to Webflow, or add a reference or multi-reference? If you have an example I might be able to take a guess as I recently spent a week trying to solve it.

1 Like

@tim28 I am trying to create a new live item in CMS with Zap but from a webflow form. It does add reference to other collection items which I am using their UUID as values.

But I am receiving the same error when testing the Zap. Any thoughts?

Hi Veronica, are you trying to generate a new live CMS item from the Webflow form, and tie it to a multi-reference field in another collection? The only way I was able to successfully get mine to work was with Webhooks by Zapier. You need to leave the multi-reference field blank in your first zap, then create a second “Webhooks by Zapier” to tie the new live item to the other CMS collection, using the Webflow ID in quotation marks if part of a series.

Testing the API call with Postman saved me from pulling my hair out.

If you want to share any screenshots I might be able to help further.

Thanks Tim! Here is a screenshot, I’ve circled the fields that are Reference Fields in Webflow. They are not Multireference fields but do they need to be wrapped in quotes “”?

I actually tried just doing the Create Live Item via Zap without these fields first but still get that same error once I try to update them in the next Zap.

Actually I was able to get it to work this. Looks like I goofed and was adding a reference from the wrong collection!

Once I made sure all the ids were mapping objects for the proper collection of that Reference field, it worked. Thanks @tim28!

Yay, way to go! I know these zaps to reference fields can be confusing, glad to try and help if I can. :slight_smile: