Streaming live at 10am (PST)

Link no longer scrolling down to section

Before my site was able to scroll down to sections on click on links, but not it just goes instantly to that part of the page. I am not sure what has changed, but it’s no longer working for some reason. Any guidance and assistance would be highly appreciated. Below is the read only and a video of it used to work before. Thanks!

Link: Webflow - new-editsScrolling issue

Hi there – Webflow made an update that will turns off the smooth-scroll feature on a published Webflow site if the user has prefers-reduced-motion enabled on the browser.

The goal here is to minimize harm as much as possible in excessive animations, in cases where users have set this OS/browser setting on.

Can you quickly check to see if the reduced-motion setting is turned on in your OS/browser?

Hi @anonymon ,

Thank you for your quick response. I am currently using Google Chrome, where can I find this setting in my browser. Is there a way to keep smooth-scroll enabled in Webflow?

I checked in Firefox and it works fine. Is there any way for me to disable this so that it smoothly scrolls as before across all browsers? Thanks!

In Chrome, check if “Smooth-scrolling” is disabled under chrome ://flags.

If this isn’t as expected, try republishing your site.

Webflow defaults respect a user’s preferences as much as possible, so there’s no way to override this setting to make smooth scrolling work across all browsers for everyone.

I checked and mine is set to “default”. I’ve never changed this setting before and I haven’t changed any settings on my browser. Any suggestions?

Are you on MacOS? If so, check System Preferences > Accessibility > Display > Reduce motion

Make sure the setting is OFF. Does that work?

Have you tried republishing the site?

I’m on Windows 10. Yes I have republished my site and that’s when I saw the smooth scrolling was no longer working, but I had exported my previous code where the smooth-scrolling is working.

Last check – let’s check the Windows setting:
On Windows 10: Settings > Ease of Access > Display > Simplify and personalize Windows > Show animation in Windows

1 Like

We’re having eng look into this case and I can update you as soon as I get more information. Thanks for your patience!

1 Like

Interesting, “Show animations in Windows” was off so that was disabled on my end. I went ahead and enabled it and now it’s working. Maybe it’s just my machine that had this off.

Thanks, I would highly appreciate that. Looking forward to it.

Hey there, we reverted the reduced-motion fix because we realized so many Windows users had this setting set to ignore smooth-scrolling. We will reimplement it once we give designers a heads up on this behavior. We want to respect a user’s preferences as much as possible, yet we understand some designers were caught off guard by the update.

Let me know if you’re still having any problems here!

hi - thanks for your posts. I’m glad you’ve reverted this until you get it sorted properly! It’s a bit problematic if Webflow make changes without informing its users! I had spent a few days trying to work out what was going on with this issue - exporting and examine the JavaScript code! The Webflow implemented this meant that for example when a Mac or iOS device was set to reduce motion - the Webflow JavaScript disabled all of the scroll to anchor code not just the smooth scroll - so websites where the anchor was designed to scroll to a fixed Navbar offset (i.e. the ‘Disable scroll ofset’ was not checked) were now ignoring the offset and scrolling to the top of the page (leaving part hidden under the fixed Navbar). Having worked out that you’d made changes the Javascript (without informing us!), I started redesigning all my existing Webflow websites to use the ‘Disable scroll ofset’ and use margin offset anchor points to compensate - this was to ensure that whether the user OS reduce motion preference was on or off) the anchor links would scroll to the correct position. So, when and if you decided to implement this again - please make sure it works with the ‘Disable scroll offset’ settings. Also please MAKE SURE Webflow informs its users of any behind the scenes coding changes, that can break websites!

3 Likes

Thank you for your sense of urgency and for fixing this up. I appreciate your responsiveness.

Was reduced-motion turned off again or is there somewhere to activate it again?

Edit:
Actually I noticed when I just have a link-block linking to another section and goes to that section immediately, however if I add a text-block and then span a link block within the text and it does smooth scrolling to the section. May be a bug, but I’m not sure how many people may be experience the same.

I have the same issue here, need to use text link instead of link block to use anchor smooth scrolling to section

Hi @e3positivity, @bryanH, @rizkimasjahri

We apologize for any confusion caused earlier without our notification of the change in smooth-scrolling newly respecting user settings.

We’ll be re-shipping this change in the next week or so. You can read about the change here:

Before we re-ship this, I’d like to confirm you don’t have issues when it becomes live by inviting you to the beta. Read this gist to give the beta a try!

If you have any questions about this feature or feedback for Webflow’s accessibility team, please reply in a thread here! Don’t hesitate to tag me or @EJ_Mason!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.