Dropdowns and other interactions won't load on published site

(Now Sorted) Hi guys after a bit of help if possible please

My dropdown menus, slider arrows, and an interaction with the nav changing colour upon scroll all work on the preview version of my site, but not on the published one.

They all used to work up until a few days ago, and now all of a sudden they’re not working.

Here’s a read-only link to the site: Webflow - Convrtem Staging

Any advice would be appreciated

Edit: I’ve tried turning the interactions off one by one to test, and also tried taking out bits of code I have in the header/body but the interactions still won’t work

I deciphered this to be your published link: https://convrtem-staging.webflow.io/
But when I attempt to view it I’m blocked due to password protection.

With the initial preview of the page, nothing works. However if I click back to the design view and then back to preview, then the interactions work.

Also see you have some custom code on the page. Have you attempted viewing the published page without this custom code added?

1 Like

Hi mate thanks for your reply

I’ve literally just found an iframe block that I tested in an old section where I had an iframe element, but it didn’t have an < / iframe> at the end in the code, and then I had the entire section set to display:none so I forgot about it

Deleted that section and now I’m back working again, thankfully

That’s nearly 2 hours I’m not going to get back :rofl:

1 Like