Dropdown OnHover not working on Chrome


This is a bit of a weird one. I have people experiencing problems with Webflow’s Dropdown element on the latest Chrome build - Version 64.0.3282.140 (Official Build) (64-bit).

I’ve set the dropdown to open On Hover, however for some people it doesn’t open on hover and they need to click the Dropdown Toggle to actually open the dropdown menu.

What’s even weirder is that I had two people test this on two different laptops, both of which running Windows 10 (64 bit) with the latest Chrome and for one of the users the dropdown worked on hover, while for the other it didn’t!

Weird, eh?

At first I thought the dropdown might be acting weird because of the styling and animation effects I added to it, but then I added a clean no-style dropdown element and it still wasn’t working. So I ruled that one out.

Can you please take a look into this? I think the problem might be in some of the JS you’re using to display the dropdown.


Hi @Alex_Tokmakchiev I’m happy to look into this issue.

can you send me your site’s read-only link?

Sure thing.
There ya go:

Hi @Alex_Tokmakchiev

Thanks so much for sharing that link. I did some testing on this end using your site. The dropdowns opened on hover as expected on Windows 10 + Chrome.

Can you provide a bit more information? Any screenshots / recordings you have of this behavior would be very helpful.

Can you also please try the following:
(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off: https://support.google.com/chrome/answer/95464?hl=en
(2) If the problem persists, please take a screenshot of your Console and send it to me: https://developer.chrome.com/devtools/docs/console

Thanks in advance!

Hey @Brando,

Here’s a screenshot of the Console. This was taken on the Windows Surface, Windows 10 (64-Bit), Chrome (Latest build), where we first detected the problematic behavior.

1 Like

Thanks for sharing that screenshot @Alex_Tokmakchiev.

I’ll pass this info along to the team to see if we can uncover what’s going on here.

I’ll reach out with an update as soon as I can!

​Thanks in advance for your help and patience :smiley:

@Alex_Tokmakchiev I wanted to share an update.

Our team was able to reproduce this behavior on Windows 10 + Chrome 64. We are currently looking into the issue to see if it’s something on our end or something on Chrome’s.

I will post back here with more information when I have it.

Thanks again for your help!

Thanks, mate!

Appreciate you looking into it!

1 Like

Hey, @Brando - any update on this issue?

1 Like

Hi @Alex_Tokmakchiev

Thanks for following up here.

I checked into the initial report we filed; at this time I don’t have an update on the issue.

As our team continues to investigate this, an optional workaround you may consider using is setting the dropdowns to open on click so as to keep them consistent across all browsers.

I’ll definitely post back here with more information as soon as I have it – we hope to have this issue resolved for you soon.

​Thanks in advance for your patience and consideration.

1 Like

I am having the exact same issue unfortunately

1 Like

I am having the same issue too.

@Brando just checking in to see if there was any update on this issue?

Thanks for following up @Dylan_Dotolo

The only update we have at this time is that this is a very specific edge case issue only affecting users with Windows 10 + Chrome 64. It seems all other combinations are working as expected.

One other workaround you may consider using if a dropdown on hover is vital (instead of on click), is to build a custom dropdown using hover interactions. The structure would work the same is in this tutorial, but you would use a hover trigger rather than a click trigger.

​Thanks in advance for your patience while we look into this.

windows 10 with chrome 64 is NOT an edge case its every single business client!

Hi @Alex_Tokmakchiev @bri-idea @Niall_Mc_Dermott @Dylan_Dotolo @Peter_Eller

Our team is still investigating this issue but have a few follow up questions.

It looks like the issue may be resolved for the latest version of Chrome – 67.0.3396.62. Can you please check to see if this is the case on your end?

Can you also let me know if any of your Windows machines are touch screen devices?

​Thanks in advance!

I can’t recreate the issue on my mac in parallels, but Yes my client has a touchscreen laptop and the issue shows up for him in firefox too

the hover property is something only for mouse interactions because on touch devices you don’t really hover ever
it seems the issue conflict is the hover property on a touchscreen that isn’t a tablet or phone
so the hover is correctly disabled on touch device so you don’t get the effect if using a mouse or trackpad?

I can confirm that on our side this problem has been reported by people using touchscreen laptops (One uses a Dell, while the rest use a Microsoft Surface). All of them run 64-bit Windows 10 (Latest Version). We detected the problem on all 3 major browsers - Chrome, Firefox and Edge.

I’ll check up with them to see if it still persists in the latest Chrome build.

I don’t see how it can be solved unless there is a way to detect that you are using a mouse or trackpad on a touch display