Navbar Dropdown not working on hover

This is a very strange situation. The site I’m building has a relatively straightforward navbar. A couple of regular navlinks and a couple of dropdowns. I set up the dropdown titles to be links themselves - no problem. I’m dealing with 2 clients in Seattle (I’m not there). The dropdowns in the navbar will not work on CHROME even though it works on numerous different machines that I’ve tried! They are using the latest Chrome version. Has anyone ever grappled with anything like this? I’d be grateful for any info/advice - I’m baffled. Thanks.

Here is my public share link:

(how to access public share link)

Hi @kerrie on latest version of chrome those dropdown links are working for me on my end.

Are you saying that on other machines the dropdowns are working in Chrome? Is it a windows based system or mac? Is it a touch device by any chance? The open on hover is disabled on touch devices, so maybe that could be a factor?

In Chrome:

I hope this helps.

Hi Dave,

I use a different navbar altogether for mobile - no issue there. They use modern windows 10 laptops, with the most up to date chrome version - and nothing happens when they hover on the dropdowns. Along with your checks, that now makes 14 machines I’ve tried it out on and IT WORKS ON EVERY ONE. Except for these two machines in Seattle, the ‘bug’ it cannot be recreated. I’m beginning to wonder if these two understand ‘dropdown on hover’ - but these are computer literate people. Anyway, thanks for taking a look Dave!