Custom domain not linking

Hello Webflow forums,

I have an urgent issue with my custom domain cry. I’ve been struggling for almost 2 weeks to connect a custom domain to my shiny new Webflow website.

I’ve entered the ‘A’ and ‘CNET’ record exact to Webflow’s instructions (I received an email from them explaining how to name them correctly as well to link it all up) and ‘published’ the website, however when I check the status still says it is unlinked, and going on the website sends me straight to the old one.

The screenshot of the Webflow page shows what to input into the DNS settings.
A - @ -
A - @ -
CNET - www -

And the second screenshot shows the DNS settings entered into the DNS portal on the current website host (X9 Internet).

NOTE When I entered the CNET record this message came up before loading. Could this have something to do with it?


I want to keep my mailbox, hence why I’m entering in the DNS settings to try and redirect the website to the new one.

I’m a bit confused by this all and I really need this fixed ASAP as the website was supposed to be live almost 2 weeks ago! if anyone can help I would really appreciate it :grinning:


Hello @JamesD21,

What about the first records that are above the two Webflow A records. Have you tried to remove them and see what happens?

Piter :webflow_heart:

Hi @PiterDimitrov,

I did this a few hours ago and the domain stopped connecting to the old site. So i tried entering the A records that Webflow suggest as the two records that were above it (see screenshot below).

After doing that I get a different message coming up when trying to go on (see screenshot below).

So for some reason it says “”. Do you think this has something to do with the A records I have in place?

Another update: just checked on the Webflow website settings and it says one of the domains are connected.

It still doesn’t connect through when I try to go on

Hey James,
have you managed to resolve this issue?