Streaming live at 10am (PST)

Can't setup custom domain

Hey folks, I’m a little bit dummy when it comes to DNS records. I asked my domain provider to set up the given records (the first option without www. prefix) - btw I’m also confused why is such an option (www or without www). In a nutshell: the first option (without prefix) working on “paper” however when I type the address it won’t load my site. The second option is in need to fix status. I’ve attached all my settings. Could you please help?




Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey @pretvari! :wave:

It looks like you have set A records on the www subdomain. You will need to remove the two A records on the www subdomain, and replace that with one CNAME record as mentioned in your Project Settings.

www → proxy-ssl.webflow.com

The reason why the root domain cannot be currently set as a default when using A records is that those A records would need to be dynamic as the IPs change for how Webflow resolves on Amazon Cloudfront across the global network, with the way this works as a CDN. The proxy CNAME records allow for resolving to dynamic IPs.

Because the IPs are not static, if static A records were set on the root domain to have the root domain load as default, it would not be optimal for everywhere, and the IPs subject to change so the website could stop working if IP routing changes.

If you want to set the root as default, you would need to use a service known as CNAME Flattening. It is explained more in this article here: Set root domain as default domain | Webflow University

Hope that all helps!
Cheers