Background videos won't play on my specific PC

I’m adding background videos to my site - first by mocking up in the test space.
Oddly, they won’t play on my PC - in Chrome, one plays for about a second before freezing.
In Brave, nothing happens at all.
But they will play just fine on my Macbook, and on a friend’s PC.

Are there any known issues or things I should check that could cause this?
Antivirus, ad blockers, anything like that?

My site’s under construction page is here:

Thank you!

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

@Ian_Connel - Welcome to the forum.
I tested current builds of MS edge, brave, and chrome in Win 11 and had no issues. Make sure your browser is updated to the current release (no pending updates). I would also advise against having two videos playing on the page unless you controlled the playback with custom code.

When you have problems with a site on a device, you should document the OS Version, browser and version. Always test in private or incognito mode to rule out extension conflicts.

I have the ability to test almost any potential combo.

I am facing the same issue. Not on my device but on my client’s PC. The background video is not playing. I have tested the website on different computers (Mac and PC). The playback worked on all the other devices.

This seems to be a specific Webflow problem. I had my customer test other sites with autoplay background videos. All of them worked. I also let her test other Webflow sites with background videos and none have played.

During testing, I found that only Webflow videos with autplay are affected. If control buttons are shown, the video can be played.

I created a new Webflow project for the tests, containing only the video. Here is the read-only link:

And the testing-page:

My customer is using Windows 10 home on an Acer Notebook with Intel. Firefox version 102 and the latest Edge and Chrome.

In my case, it turned out that my client’s computer had reduced motion settings enabled.
When this setting is disabled, the background video autoplay works. I didn’t realize that these settings would affect the playback of the background video in Webflow. To me, it was odd that the background videos on other websites worked.
However, I think this is a good thing for accessibility.