Background videos are not loading

Hey, this is my first webflow site and I’m having trouble with background videos not loading.

I have 3 background videos on the home screen. One on the hero screen [section 13], and two more in the industry recognition area [sectiune cherie]. I’m not sure what the problem is, they work fine when I preview the site, but don’t load on published sites.

The site is not done and needs polish, but let me know if you guys see any other problems with the site or have opinions on anything, thanks for your time!


Here is my site Read-Only: Webflow - Rift Media

Hey @Hereafter,

I took a look at your site in Google Chrome on MacOS and all three of the videos are working. Can you provide some more context like what device? what OS, is your device in Low Power mode? Thanks!

Ps: welcome to the community!

1 Like

Thanks a lot for the suggestion and your time @austin !

Ok, great, that’s reassuring to hear. So it might just be something on my end given my current device. I don’t see why that would be the case, I have optimized my desktop for performance, but let’s troubleshoot anyway.

My device: 1920x1080 x64 desktop running windows 10 pro N (media feature pack installed), great CPU/GPU/RAM as far as workstations go, power settings are default, and I use google chrome.

I don’t have trouble loading media on any other website, I can even load this exact website on the preview page; just not on the live published page. I will try the site on other devices to see if it works and report back, but would like to still try and figure out why it’s not working on my specific device. Thanks a ton.

Edit: Tried the website on all sorts of different devices and displays, and everything works fine. The problem is only with my own device. Installed some video extensions I was missing (VP9 Video Extensions and HEVC Video Extensions), but the problem still persists. Tried the website on firefox and chrome incognito (also tried normal chrome while signed out of profile and default settings), problem still persists. I’m not sure where to go from here, maybe a GPU or graphical setting in bios?

In case anybody else needs help with this, I figured it out.

There’s an issue with background videos not playing when reduced motion preferences are enabled. To disable, go to:

In Windows: Settings > Ease of Access > Display > Show animations in Windows.
On Mac:Apple menu > System Preferences, click Accessibility, then click Display.

This fixed it for me.

1 Like