Website loading very slow - Solved - Reason: Google Optimize

Dear Webflow Community,

My website is loading very slowly. It takes around 4 seconds!

It contains several videos that are embedded via custom code with external hosting on AWS.
But it seems that is not the problem

→ Loading the content seems to be completed after 1600ms.
But it takes another 2-3 seconds until the screen switches from white to showing the content.

Here is a video showing this behaviour.

The loading time seems to be independent from the content as even pages with feewer content take the the same time to switch from white to showing the content.

What could be causing this? Can anyone help…?

Here is my site Read-Only

I think I was wrong with my previous assumption. It seems now that the slow loading IS INDEED related to loading the videos…

See new screencapture video

But nevertheless, does anybody know how I can set the page to show all other content even before a video embedded with custom code has been fully loaded?

Thanks for help.

Yeah this is probably due to the videos. You could try loading them after the rest of the content on the site. I belive you can do this with the Webflow interactions.

Awesome. Will give this a try. Thanks. I’ll keep you posted if it works…

1 Like

Hm… :frowning: Unfortunately it doesn’t work, as animations don’t allow triggering the LOADING of an element but only HIDING/SHOWING the element.

See video

Ah I see. Try finding a way to lazy-load the videos with a JS-plugin maybe?

Also Have you tried checking the page-speed with a tool like “GTmetrix” or “google pagespeed insights” Maybe you can find some clues about what might be slowing down the site there.

There could also just be that the site is not hosted with a payed hosting plan. I don’t think the free domains are as fast.

Solved!! It was due to Google Optimize. I still don’t know why it caused the slowdown. But as I removed the Google Optimize code from the page settings the page loaded super fast again.


Hey, that’s awesome!

1 Like

Thanks Felix for your assistance. Really appreciate it :slight_smile:

I had the same issue. Took an hour or two to get to the bottom of it. Seems like the culprit is this anti-flicker timeout feature that they have. See:

Generally this shouldn’t cause a problem but it does when Optimize fails to load somehow. I haven’t figured out yet why it does on my site. Maybe some bad setting.

For now I’ll just go to my marketing person and give him the bad news but I hope that we can get to use optimize at some point