Webflow Form + Zapier Help?

Hey everyone. I’m just setting up simple Zaps to populate a Google sheet with submitted form data from Webflow.

I’m having an issue, any ideas?

When selecting which Form from Webflow to use, only one form is appearing. There are at least 3 forms on this website. I figured the issue might be that all the forms are named the same, so I went in and gave them new names and IDs (I remembered to publish (multiple times)). It’s been most of the day now though and the other forms still aren’t appearing on the dropdown to select them for use in the Zap.

I’ve tried refreshing the data, and i’ve also tried disconnecting and reconnecting my Webflow account from Zapier.

Any help would be GREATLY appreciated.

Yea that’s strange. Can you upload 3 screenshots showing each of your different form names setup within Webflow?

Yeah here they are:

Odd. Can you re-publish the site, view source on each of those pages, and find those form names? If so how about 3 screenshots, 1 of each?





Try this.

  1. Create a NEW Webflow Project. Add 1 Form to the home page, rename it, only change the Name field (the ID field, I believe, will change to that value prepending some of it’s own sugar).

  2. Create a NEW Zapier zap. Trigger it on Form Submission from Webflow.

Does that work?

  • Yes.

    1. Add a new page to your Webflow project.
    2. Add a new form.
    3. Change the Name field just as you did above.
    4. Add a new Zapier zap.
    5. Set it up like you did above.
    • Does that work?
  • No.

    • Hmmmm…

This did not work. Zero options were available for the form selection on Zapier:

Seems to be a bug at this point. Maybe Webflow will get back to me within 168 hours. :stuck_out_tongue_winking_eye:

Gosh, that is so strange. Sorry I couldn’t help :frowning: But yea, hopefully you’ll get some help from Webflow, post an update when you do!

No worries! Thanks for trying! I got one email back from them, got some additional info over to them so hopefully the next one will be some sort of a solution from them :smiley:

Definitely, will do!

1 Like

Hello @jackwabbithave you tried to submit these forms? Zapier works a lot better if you submit the form once and it will pick up the data as well making it easier.

1 Like

That’s probably the issue :+1:

1 Like

Hi, yes hundreds of submissions go through these forms daily.

So, haven’t confirmed yet but i’m guessing this is the issue:

Webflow shows that i’ve only used 96/1000 submissions for this period, but hasn’t captured submitted forms in 10 days. I know for a fact hundreds of form submissions have gone through though, I store the data elsewhere.

Going to upgrade my account to unlimited form submissions and see if it fixes it. Seems to be some kind of bug that’s got the submissions halted.

UPDATE: Upgraded account, submitted form, still not captured. In the meantime, Webflow support is sending me videos showing me how to set up a form and Zap like that’s the issue :joy:

1 Like

Interesting. How about on that small test with a new Webflow Project and new Zapier zap:

  1. Did you submit a form on it first?
  2. Did the form submissions show up on your setting screen (as shown in your screenshot above)?

Here’s another thing to try. Signup for a new, free Webflow account with a differing email address. Try the small test project again and see if it works.

1 Like

I ended up recreating the forms that were having issues and that fixed it. I tried changing one thing at a time to pinpoint the issue, but couldn’t figure out what might have been bugging the old form.

Anyways, i’ve got a working form that shows up in Zapier now so at least I was able to reach the end goal.

Maybe just a weird bug.

Thanks for all the time and care you put in helping me navigate through this Chris! Much appreciated.

1 Like

I was having this problem also. Then I found this post: Form does not appear on Zapier

You have to submit the form once via your site for zapier to see it