Webflow form error while trying to submit the form


I created a page with forms that were working really well. I connected them to Firebase via Zapier, and everything worked perfectly. Today, I implemented Stripe’s one-time payment feature, which worked fine. However, I don’t know what happened, but suddenly, the forms stopped working. Whenever I try to submit a form, I get an error message saying “Oops something went wrong”.

I tried looking for solutions and found that it might be a reCAPTCHA problem, but it was turned off. I also tried turning it on but it didn’t help so i turned it off again.

Even the forms that I created months ago don’t work and have the same problem. I created a new project with a simple form with only a name and email, but it also doesn’t work - same error message.

I don’t think I’ve exceeded my free form submission limit (50 submissions), as I have a paid plan, as you can see in the attached photos.

I’m not sure if the problem is with Webflow or if I really overspammed the forms. I suspect it might be something like that since the problem affects both old and new forms. It’s really frustrating since everything was working well before.

Thank you.

Most likely the former, reach out to support.

1 Like

Thanks Chris for the answer.
It started working now, couple hours later without doing anything. :sweat_smile:

Hi there, I am having the same problem, sometimes, my forms stop submitting. I connected them to airtable via Zapier I have 33 forms on a page for document uploading. but after 10-11, form submissions stopped working, and every form on the site stopped working. I want to fix it, can’t mess with the client experience.
Please go through my read only link : Webflow - National Tax Incentives

Please help me out. thanks in advance