Streaming live at 10am (PST)

Urgent help! Can't place orders!

Live store is no longer working!

It worked a week ago and now doing a public launch and the place order does not go through! Please help, we actually have customers waiting to pay :frowning:

1 Like

Hello @Octa_Creative,

maybe you should contact support directly

Hi Pablo,

I have! Was hoping someone on here may of had a quick solution. Webflow support will take some time :frowning:

Thanks though!

No worries @Octa_Creative, good luck.

I guess I am affected by the same issue today.

Its only been today this has happened. Nice to know it’s not just us.

I’ve spoken to stripe and nothing is wrong their end. It’s a Webflow issue. We’ve lost out on £80 worth of sales so far (that we can confirm) customers are messaging us with their order issues… its so disappointing. I moved my client from Shopify too :man_facepalming: Hope Webflow gets back to us ASAP! Support takes 24 hours just to get in touch :slightly_frowning_face:

1 Like

Yikes. I moved from Shopify as well.

It’s easier to build pages in Webflow but e-commerce = money = !!! critical !!!
I also tweeted at their CEO and support. I hope they can reproduce the issue and fix it soon.

1 Like

Hello, hello!

@Octa_Creative @Terry_Xu @Pablo_Cortes

Thanks for posting about this Ecommerce issue.

A recent error around checkout was identified and resolved following our latest update.

Please republish your ecommerce website to ensure that this checkout update is effective immediately.

Head into the Designer or Project Settings to do so. You can even republish from the Editor:

Let us know if you are still experiencing any odd behavior!



My site is currently facing the same problem, customers cannot place their orders - they enter all of the card details and then click the place order button, the loading text appears and then nothing happens.

I have republished my site and the problem persists.

Can you please help with this?


@AmyZ can you please help with this? I have not had any response.

Hi Matt,

I panicked for a moment but we’ve checked out site and its all working on our ecommerce. Not sure how much you’ve tried… so don’t shoot me here but maybe try these.

  • Reconnect stripe.
  • Talk to stripe on their support chat to double check its not an issue their end. That way you can say to webflow its definitely a webflow issue.
  • Disable and enable checkout

Just a few things to try out while you wait.

Hopefully @AmyZ can get back to you with some more official help

Thanks for the reply and appreciate the suggestions.

I had an extensive discussion with Stripe and they confirmed that everything was working from their end.

The stripe account is activated and live, I have disconnected stripe and reconnected, enabled SSL and disabled and enabled checkout but it is not functioning as it should be.

I’ll wait to hear back from Webflow.

Thanks again.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.