Unable to style input text

I’m trying to style the text that is typed into any of the text form fields in a form located in the “Let’s Talk” section of my web page. This Webflow lesson says that I should be able to toggle Preview mode on, type some text into a field, toggle Preview mode off, and then the text will appear in the form field and can be styled from there. But when I follow these instructions, toggle Preview mode off, and go back to the Designer, the text I typed in is gone. All I see is the placeholder text. Is there another step I’m missing to make this work? Thanks!


Here is my site Read-Only: My web page

Hey Robert,

I don’t think you’re missing a step. I styled the input text by making it yellow, and it will show the styling in Preview mode when you type into the form field. Not sure why the instructions from the tutorial are not working. Perhaps a bug, outdated or incorrect.

Marcel, thanks very much for taking a look. But I still don’t understand how you’re typing your name (Jeff) over the placeholder text (First name) while you’re in Design mode. To enter text into the field, the only way I’ve been able to do it is in Preview mode. However, once I go to Preview mode, type something in, and then go back to Design mode, the text I typed in disappears and I see the placeholder text again.

Hi! I think this is how it is supposed to work; you should see the placeholder text anytime the form is not in use (like in designer mode). If you want to change the actual placeholder text font, you can click on your form field, and then the drop down, and then place-holder. Then you can style the text however you want. I hope this helps!

Thanks Jordan but I don’t want to change the style of the placeholder. I want to change the style of the text that gets typed into the form field. As things stand right now, if I type some text into the field, it’s darker than the placeholder text, so much so that you, as the user, can hardly see what you typed in. I want to change it to a platinum white like the text in the content area to the right of the form.

1 Like

Hi Robert! I’m sorry! I think all you need to do is change the typography settings on the ‘let’s talk form field.’ It won’t show up until you preview the site, but once you type something in, the font and color you picked will show up. I tried this out on your read only page, and it looks like its working ok.

1 Like

Jordan, thanks so much! That worked but it highlighted an issue I’ve run into before. After I read your message, I re-published the form since the typography color was already set to the color I wanted. And again, when I typed some text in, it was dark, not the color the field was set to. So I went and changed the typography color to a different color entirely (red) and re-published the site and this time the color was red. So I then changed it back to the platinum white color I want and now text that is typed in has that color. I’ve had this happen before where if a typography color isn’t what it’s supposed to be, I have to change it to something different and then change it back to the color I want before it works. Anyway, thanks again for your help. I really appreciate it!

Just stopping by to say I had the same issue and this helped, is this noted as being a bug? The body default that’s applied should be working from the get go