Streaming live at 10am (PST)

Unable to add CNAME for .app domain

@dannybster - I would like to help resolve this issue. I just need the domain name you registered please so I can look at the zone data.

Sure, sorry thought I had included it in original question. Domain is tweaky.app

Thanks!

What is your desired config? Hosting www.tweaky.app as the default or tweaky.app?

1 Like

I’d like tweaky.app to be the default if possible, I have just set it to be default. According to my dashboard it should all be working (I’ve attached an image).

On Google DNS CNAME records cannot be set for the root domain.

Meaning you need to use www.tweaky.app as your default domain(or a different subdomain).

Please set your two A records to 34.193.69.252 & 34.193.204.92

Add a CNAME record
Set the host to www
Set the value to: proxy-ssl.webflow.com

Google automatically adds .app dns records to the HGST preload list, which browsers are configured to check. All hosts are required to support SSL connections.

Note : When you make changes to a resource record, It could take up to the length of the TTL time for the change to propagate. When you add a new resource record, it will be visible to Internet users in about 5 minutes.

1 Like

Hey :slightly_smiling_face:

Maybe I am being slightly dense here but I have setup the A records and the status in Webflow is connected (although they won’t resolve). I am unable to set any CNAME in Google Domains so cannot add “www CNAME http://proxy-ssl.webflow.com

I receive the below warning regarding setting up CNAME (option 2) records from Webflow.

Thanks
Dan

You can’t include the protocol on the CNAME host. Just add the FQDN = proxy-ssl.webflow.com

Ah sorry that was a typo from the forum software treating it as a link when copying and pasting - did not include protocol.

Try following this video exactly. Let me know what happens. Use .com instead of .io in the video.

CloudApp

I know this works. I have a .app domain on Google domains with Google DNS. Just note that Google DNS does not allow for multiple A records pointing to @. So use the first one as shown.

CloudApp

You could always move your domain to Cloudflare. They support either configuration and domains are much cheaper(wholesale).

Ok had a go at this no joy but am unable to upload videos so have attached 2 screen shots. I have just spotted your message below and am likely to just move my domain over to DNSimple.

Would it be possible for you to screenshot the whole page (no left sidebar needed) page that shows the domain and all the other sections above? You could PM me with that if you don’t wish to share it publicly.

I would add a correction to my previous post regarding more than one A record data value. Google does support it. I missed the +. I have been running my own DNS infrastructures for many years and each interface is a little different. I’m used to VIM.

You really should open a ticket with Google. My settings show it can be done.

CloudApp

I have begun the transfer process over to DNSimple, it just seems “simpler” having done similar in the past. I am only using Google Domains because they offered .app TLD’s early.

I’ll let you know how it goes!

Thanks for all your help! I have transferred over to DNSimple and have moved a step further. Both tweaky.app and www.tweaky.app are now in the connected state using Webflow Free SSL.

However now when I visit them I get an ERR_SSL_PROTOCOL_ERROR in Chrome and the following screen shot complaining about an expired certificate in Safari.

50

You may need to wait a bit for the propagation

CloudApp

Also, make sure that your WWW domain is set to default in Webflow and not your root domain

1 Like

Thanks! I have waited for propagation to happen over night, and can confirm that whilst not totally propagated, it has propagated to my current DNS. I have tried to access my site from my current location, and my proxying to various different locations and all give me the below error:

I found many other forum posts relating to this issue of which [Resolved] Err_ssl_protocol_error is one. Am I doing something wrong or are there some SSL issues at the moment?

Thanks
Dan

To try and debug this I have bought another .app domain shipd.app, and set that up on the same project and it works fine almost instantly. I am still unable to get tweaky.app to work, this is starting to look more and more like an issue Webflow end. Can somebody check my account and ensure that SSL is setup correctly for tweaky.app please?

Thanks
Dan

id 44620 opcode QUERY rcode SERVFAIL flags QR RD RA ;QUESTION tweaky.app. IN NS ;ANSWER ;AUTHORITY ;ADDITIONAL

DNS failure. You have no DNS servers defined. Not webflow.

It seems that I do, especially since I type in tweaky.app and it successfully redirects it to www.tweaky.app as I had defined in Webflow. I have followed the exact steps outlined except one works (shipd) and the other does not (tweaky) please see attached


@dannybster

According to Google G Suite toolbox you don’t. That would indicate a propagation problem, since they are the default registrar for the .app domains and where you registered yours. The whois for that domain does show the new nameservers.
See screenshots.
CloudApp
CloudApp

Please open a ticket with your registrar.