Streaming live at 10am (PST)

Keep getting error messages on CNAME when DNS provider says all is well

So my DNS says all is well and it has been 5 hours since propegated.
my site is www.electratsoy.ca

Looks like webflow is the problem, but I have no idea what to check or do.
If anyone can help, it would be much appreciated as this site is pretty time sensitive.
Thank you!!

Just was looking at webflow help, and tried to add a CNAME as suggested.

Update your DNS settings
Access your domain’s DNS settings, and add two records:

(just did this)
Add ANAME or CNAME record for the root domain (host: @)
Add an ANAME or a CNAME record
Set the host to @
Set the value to: proxy-ssl.webflow.com

(had done this, as you can see in my 1st screen shot)
Add a CNAME record for the “www” subdomain
Add a CNAME record
Set the host to www
Set the value to: proxy-ssl.webflow.com

NOW, my www and my .ca are showing ISSUES detected


OK> removed the CNAME @ record and at least the electratsoy.ca is FINE.

Still getting errors on my www.
Please help me, as I REALLY need this up this weekend. (tears!!)

Did you resolve this? I went to www.electratsoy.ca and things worked on my end!

Let me know!

Yes, well sorta!!

I have a professional account registered with webflow, so I just moved it back to my account and voila - it worked.
I had transferred the site to an individual account and had set them up with just basic hosting.
Don’t know why it worked on one account (just a regular hosting account) and then when I removed it from her account (deleted it) and re-opened it in my account that it worked.

1 Like

Hmm, very odd. I wonder if it had anything to do with not having enough time to propagate the changes, though that usually happens fairly quickly.

Regardless, I’m glad you got it resolved in time for the launch this week!

Yes, it did have time to propagate - 5 hours to be exact. I also checked it on DNS checker and it was all good.
I set up the new account. Then transferred it to her account from mine. Then I set up hosting and went to my domain and set up the A records and the CNAME. the electratsoy.ca was fine but the www.electratsoy.ca wouldn’t connect in webflow. I verified it 3 times with Rebel and they said it was all fine.

Any idea why it wouldn’t work with the new account?

I wish I knew, but maybe @Brando or @Waldo has more experience with this issue?

Sorry I couldn’t be of more assistance!

Hi @danandmic, thanks for your message. I checked and currently the dns records look ok. I did see from the original screenshot that the www was not selected as the default domain and that would have been an issue when using the a Records, but now I can see the domain is connected properly to Webflow, so it might have been dns propagation.

The account type you have has no bearing on the custom domain dns, the issues detected message shows if propagation has not yet completed or there is some other DNS issue.

Now the site is loading as it should on my end, let us know at support@webflow.com in case of any issues with the custom domain or connections, we are here to help.

1 Like

had similar issues all day today. Every 30 minutes for about 2.5 hours straight… Webflow would tell me to add 2 different A records to DNS. First it would say add and …… then 30 mins later it says these are the A records I should add: and

So within the Webflow “Hosting” tab, I kept getting “issues detected” and then “connected” on both custom domains (www or non www) … it swapped dozens of times between these two status messages. still not sure what A records were correct.

similar issues with another launch today. 4 hours ago I added the 2 A records and the CNAME record to the client’s registrar/DNS settings. 80% of the time in the last 4 hours, the Webflow “hosting” tab says “issues detected” next to both the www and the non www URL. Why does this take so long every time? What else can I do other than hope “issues detected” goes away?

Hi @dreweastmead, the dns changes can take up to 24-48 hours, but are normally propagated within minutes.

I would also check that your domains are connected to nameservers that are managed by the same registrar, i.e. you cannot point the domain name at different nameservers from different services.

A good thing to do if the domain is not resolving is to do the following:

  1. Remove the custom domains from the hosting tab of project settings
  2. Re-add the custom domains on the hosting tab
  3. Set the WWW domain as the default domain
  4. Publish your project

If the issue persists, contact our support desk by filling out our contact us form at: https://university.webflow.com/support

I hope this helps

Thanks. Nameservers are correct.

In the future, at what point do I remove the custom domains and re-add them? After 1 hour? 2? 3? 12? 24? The guessing game is really frustrating. Should I remove and add the custom domains, or is that going to essentially reset the 24-48 hour propogation period?

I know this is not necessarily Webflow’s fault, but there has to be a better way to tell the GoDaddys of the world to hurry the hell up.
It’s now been almost 24 hours since I updated the C NAME and A records, and I am STILL getting inconsistent results on the domain depending on what machine/browser I use.

Hi @dreweastmead, this seems to be an odd case where it seems the nameservers were updated, but for some reason the NS records at bluehost seem to still be active somehow, so the dns lookups are intermittent.

Just as a confirmation, did you already remove all custom domains, then re-add and set the www domain as the default domain? After that, republish the domains. I usually do this after about an hour of changing dns settings if things are not working.

In general I usually first change the dns settings, then add the domains to Webflow. Sometimes if the domains are added first, a reset on the domains in the hosting tab by adding and removing and republishing will help to sync things up.

I should note however, I have tried from multiple locations and cannot see any errors in the published site, it is displaying secure on my end and from several remote machines with no issues at the following domains:


Thanks again Dave. Appreciate all your help and time today. It seems the website is working for about 80% of people. Still getting some reports of the site timing out.

I agree something about BlueHost is not helping; I’m not sure how to kill those NS records @ BH … I would think changing the nameservers in GoDaddy to the GoDaddy default nameservers (which I did 24 hours ago) would render all things BlueHost moot.

Hi @dreweastmead, well the good news is that at least it seems like propagation is continuing, I see one less nameserver timing out, so that is good news.

I would let it sit over the next 12 hours, if the issue continues to persist tomorrow, let me know and I will help to dive deeper. I know dns updates can be frustrating, I look forward to the day when Webflow becomes a registrar of domains and have our own nameservers :slight_smile:

Thank you again Dave, and I look forward to that day as well !!