Streaming live at 10am (PST)

Typekit fonts not loading

I have had this displaying since I first attempted to install Typekit fonts about three weeks ago. Any ideas please?


Hi, do you have your typekit font api key specified in the Integrations section of the Account settings page? Cheers

Also, does it still show up if you refresh a couple times? There’s a bug causing this that we’re tracking down.

Hi cyberdave, thanks for checking but yes I have specified the API key. I have also tried using a different key from Typekit. As thesergie says it is a bug. Cheers.

Yep, tried that also. The message is there and has been everytime that I log in since first trying to install the fonts. If you need any other information to track down this bug just let me know. Thanks.

@Allan_Nutbrown about how many kits do you have in your account? There may be an issue when there are too many kits in your account.

Hi brryant, Thank you for your response. I have 23 fonts in my Typekit account. I’ll reduce that to one typeface with three or four fonts, see if it works and post the result.

I am also having this issue. I only have two fonts in my typekit account but it is stuck on “Loading kits from TypeKit …”.Has there been a solution to this yet?

I am having the same problem. Tried everything. Anyone with a solution to this problem?

Hi @JonasGoth, Hi @Allan_Nutbrown, Hi @robskinn,

Thanks for your messages. Can you please go to your Typekit control panel in, and from their, you also need to authorize the domain you are using that is hosted on webflow. If this is a subdomain, like, then authorize that domain to use your Typekit fonts. Can you check that first, then if still an issue, let us know? Cheers, and thanks !! Dave

Hi cyberdave,

Thank you for your interest on this, I just authorized two fonts and no still cant get it to work.

Cheers, Allan

Hi @Allan_Nutbrown, thanks for your update, could you share your site public link, it is read only, no changes can be made to the site, and you get that link by clicking Enable Public Link from your site settings page. Then we can look to see what may be your particular issue. have you already entered your typekit key for your personal account?

If this is for a Team Plan, and you are working on a site in your Team Site Dashboard, have you checked that your Typekit key is entered for the Organization? That is one other thing it could be as well, here is the instruction on setting your typekit key if this is for an organization site:

Can you check that, then share that link, and we can look further. Cheers ! Dave

Thanks for the quick response. I am not able to do this now but will check it over tomorrow, do as you suggest and get back to you.



Hi cyberdave,

Yes I have entered my Typeit key for my personal account. Here is a link to the site, as you can see I can add a custom font but still struggling with Typekit. Thanks in advance for your help.



Hi there @Allan_Nutbrown, sorry for late reply. On your example page, you have a font of marytodd for the header title, and arial for the text ( from the designer) When I look at the published site, I am getting the same font…

What font name are you expecting to see?

Cheers, Dave

Hi Dave, the font from Typekit that I can´t get to load is Adelle. It does not appear in the lit of fonts in the designer although it is on the dashboard. When I click to install it the drop down says it’s been installed but it hasn’t. Sorry to be so late in replying.

Cheers, Allan

Hi Allan, can you send us a support email if you’re still experiencing issues? Thanks!