Streaming live at 10am (PST)

Typekit Font (Futura) does not properly display

I followed the described Typekit integration. It al went ok and I do have my font (Futura) in the dropdown menu in the editor. However, when writing text in Futura it dies not display in Futura.

So how can we fix this?


Hi @PhillipB. Can you try one more time? We had some problems yesterday with Typekit and we fixed it. Let me know if you’re still running into it.

Well, the problem still appears. It is also that in the Font Dropdown menu Futura PT is previewed more in a Times New Roman Style. So there is some wrong with the integration.

I’m running into the same problem! This doesn’t have to do with the Typekit bug I was talking about. It’s like any type element I select doesn’t show the correct typeface. It seems like it started happening this last week. Time to fix this baby!

We just pushed a fix! The font family now shows up correctly.

Nope, it still does not for me.

I even started a new project to test it. But it looks like the bug is alive. :slight_smile:

Same for me. Proxima Nova and Brandon Grotesque both show up as Helvetica.

@PhillipB and @Brendan_Fagan does the font display correctly on the website, but the drop-down shows the wrong font name?

Displays as Helvetica on the site and some sort of serif (georgia?) on the menu.

Can you guys tell me what you see in the Domain field when you click on Kit Settings in your Typekit?

Here’s mine.

So it looks like I fixed it by starting a new site with a new Typekit API key. Thanks for your help Sergie!

Did you just create a new site and it worked or did you create a totally new Typekit account (which has a new API key) and replaced the old API key with the new one?

I’d love to know so we can see how to help others with the same problem. :slight_smile:

Sure thing. I created a new kit, new webflow site, and generated another API on this screen.

Awesome thanks for the info!

I’m having a similar issue with Typekit on my site with Proxima Nova. It is displaying a different font. Is the only work around to create a new Typekit account / API key? That seems silly.

Update: It looks like the font displays properly when published but not while editing in Webflow.

Having the same problem with Proxima Nova Condensed (also Typekit via API) within the editor. It shows on the live site, but does not show at all in the editor.

Also it seems that the “thin” variant of Proxima Nova does not show when I select it. Works as well on the live site.

Okay, here’s how to solve it: add to the allowed domains inside typekit. It didn’t cross my mind I had to do that as I thought this would somehow be handled through the API by webkit<->typekit.

To add to the confusion, Proxima Nova was showing up in the editor, while Proxima Nova Condensed was not (both in the same typekit kit).

The JS-error however (“Typekit … forbidden … could not be loaded”) gave me the idea I had to look at the domain settings as I had this error before on live pages where I forgot to add the proper domain.

1 Like