Streaming live at 10am (PST)

Text changes are not saving or publishing to live site

I am unable to make any persistent changes to text in my project. Although I can change text in the editor the changes are not published to the live site and disappear when I reload the editor.

This is very frustrating because I am unable to finish a client project and am trying to finish text corrections since two days. I saw that many people reported this bug. Is there a fix ready?

The site is:

Thanks in advance!

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi, @luoa!

I’m so sorry to hear you are having issues making updates to your site. It’s definitely no fun when things don’t work the way we expect them to.

I made a copy of your site and imported it for testing and I was able to make changes using the Editor and publish them.

We did have a small issue with the Editor on Monday, but the team pushed out a fix for this and that has been resolved.

There are a few factors which could cause this, your internet connection, ISP (internet service provider) issues, older browser versions, browser extensions, or of course a bug.

Can you:

(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off:

Or if you are using Safari, in Private mode.

(2) If the problem persists, please take a screenshot of your Console and send it to me:

(3)Could you please let me know what browser version you’re using by sending me your information from this page?

I’ll be standing by to help when you reply!

Hey Riley,
thanks for your quick answer.

(1) I could reproduce the error in Incognito Mode with all extensions turned off.
(2) There were no errors displayed in the console.
(3) Here is the info about my browser:


Hi, @luoa!

Thanks for that information! Would you be able to use a tool like Cloud App to provide me with a short video about this issue? It would be nice to see what’s happening in action.


sure here is a short recording of the issue:


Thanks so much for that video. Could you try one other thing for me?

Could you try making that same change, or change some other text? And when you’ve completed the change could you do a manual save (CMD + S or CTRL + S) and then publish and let me know if you get a different result?

Hey, no worries. I tried changing the same text like you said and save it manually but still nothing showed up when i published to the live site. I also tried editing another piece of text which actually worked and got pushed to the live site. This also supports my experience so far that this issue only occurs with some but not all text elements.

Any ideas why this might be?

Hi, @luoa!

Sorry for the delay in response. I can’t seem to reproduce the problem no matter how hard I try. I have passed this on to our engineers to see what we can track down. I’ll let you know as soon as I hear anything from the team!

Hi, @luoa - when investigating the site we’re seeing the changes you made and published in your video. Maybe this is an issue with browser cache?

Are you still not seeing the changes? Looking forward to hearing back from you!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.