Streaming live at 10am (PST)

SSL Not Passing Through To Cloudflare

Hello, my client’s site diabetespac.com launched today, but the SSL is not passing through correctly to Cloudflare as expected from all my other identical deployments, like the sister site diabetesleadership.org … Both are using cloudflare, but the pac site is still trying to pull webflow ssl, but not using the ssl a records, nor the ssl-proxy cname.

If anyone has any experience troubleshooting an issue like this, I would be very grateful.

Here is a recording of the two cloudflare setups sidebyside - tpzZOAXS0t.mp4 - Google Drive

Thank you.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @Colton_Bowshier, thanks for your post. I am not 100% clear if you are trying to use your own SSL or if you are having issues with getting Webflow SSL to work, can you help to clarify how you are trying to host the site?

To use your own SSL is a feature of the Webflow enterprise plans, see here: Webflow Enterprise | Build smarter.

Here is how to use SSL hosting in Webflow: SSL hosting | Webflow University

Usually the first good place to check for issues is on the hosting tab of project settings where you have the diabetespac.com connected and check for issues detected.

The next step would be to check and update the DNS records on the domain(s) to point the DNS records at the correct servers.

The root domain (without www, like example.com) should have these two A-records:

Type: A
Name: @
Value: 75.2.70.75

Type: A
Name: @
Value: 99.83.190.102

The WWW subdomain should have a CNAME record and should use the following values:

Type: CNAME
Name: WWW
Value: proxy-ssl.webflow.com

​If you happen to be using Cloudflare, the Status column on your DNS records that point to Webflow must be changed from “Proxied” to “DNS Only”.

After DNS changes are made, got to the hosting tab of project settings, set the
WWW domain as the default domain and then Publish your project.

If the issue persists, you can also contact to Webflow support for help with the custom domains: Webflow Customer Support | Webflow University

For Lite, Professional and Team plans (Teams which are not on Enterprise plan), you would normally configure the A Records and CNAME records to point to Webflow servers, then you would disable the Proxied status in those DNS records in Cloudflare and use the DNS Only option.

Here is the Cloudflare integration page with more details: Cloudflare Integration | Webflow University

With the domains connected in DNS, the SSL will be used automatically for the connected domains.

If you are using Webflow SSL, then the SSL mode in Cloudflare should be set to off or Flexible:

Shared with CloudApp

It sounds like the diabetesleadership.org domain may be connected to Cloudflare and Webflow with the SSL in Webflow currently turned off. You can check the Hosting tab of project settings for each project and check the Enable SSL button to see if it is on or off:

Shared with CloudApp

If the Enable SSL is off, this means that Webflow SSL is not enabled and Webflow is serving up pages over http only.

If the Enable SSL is on, then your domain connected in the hosting tab need to be connected via the DNS records I mentioned above with the SSL mode in Cloudflare set to Flexibile and the Status column in the Cloudflare DNS records set to DNS Only.