Streaming live at 10am (PST)

Cloudflare DNS Settings with Proxy

Hi all,

Just want to double check that what I’m doing is correct. We’ve migrated a massive site from Wordpress to Webflow, the thing has thousands over very old poorly optimised images so we’re going to go the Cloudflare route so that I’ll do the optimisation on the fly. We’ve got it set up so that assets-global.website-files.com is acting as a bucket and Cloudflare is resizing and optimising the images and then caching them on a subdomain and serving them from there.

The tricky part is getting the SSL to work correctly with the DNS settings on Cloudlfare when it’s proxied. Had it running with SSL turned on in Webflow for a while, but eventually the certificate fails and doesn’t renew due it it being proxied on Cloudflare, so now I’ve got SSL turned off in Webflow and then on Cloudflare I’ve got two A records for 104.156.81.229 and 23.235.33.229 and then the CNAME pointing to proxy.webflow.com, then the Cloudflare SSL mode is set to full.

Has anyone tried this and did you run into issues?

Also, let me know if you’ve got Cloudflare running with a different configuration and have it proxied without any issues.

Thanks in advance.

Hey @J8kes - just curious, did this setup work for you? We have an existing site that we’re looking to add Cloudflare proxying to for some complicated routing reasons, but last time we just enabled it as-is we ran into the same cert issues.

@dcala So i’ve got SSL disabled and using the no SSL settings in DNS in CloudFlare (so I think 104.156.81.229 and 23.235.33.229 proxy.webflow.com) and then under SSL it’s Full. Seems to be working just fine now, Cloudflare then handles all SSL on their end.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.