Streaming live at 10am (PST)

[SOLVED] Weird Canonical Tags showing on Google Search Console

My company recently hired an external SEO consultant. On several pages (40+), the report stated that the canonical is incorrect. It seems as though it has some sort of glitch where it lists the domain, then includes the actual canonical link in quotes after that. This is also reflected in our Google Search Console.

As an example, our What’s New page links back to itself for the canonical. Our SEO consultant’s report states that the canonical is:“”

Google Search Console agrees with this finding as seen in the screenshot below:

When adding the canonical tag, I followed the instructions on this Webflow Guide so I’m not sure what is going wrong.

You can see that the link in the page settings of the Designer are correct, and when I go to the source code of my page the canonical appears correct.

Even more strange is the fact that this is only happening on some of my pages despite the fact that I added the links the same way on all of my pages.

Why is this error happening on so many pages but not all?

read-only link

After reaching out to Webflow support this has been solved (thanks, Mark!).

The quotations used around the link in the custom code of that page were incorrect. They were left and right specific quotes instead of straight quotes. Looking back at the stated canonical, you can see the unicodes but I hadn’t recognized them at the time.

After changing those quotations and doing a Live Test in Google Search Console, the stated canonical is now correct.