Canonical tags incorrect on CMS collection items bug? 😬

I’ve just found a bug on two Webflow sites I’m developing where Webflow is generating an additional incorrect Canonical tag on CMS collection items. This is very damaging to SEO :skull:

No response from WF Support after 24 hours, so I’m now wondering if everyone is getting this bug?

To test, republish your site and navigate to a collection item on the live site (such as a blog post). Then, view the source code on that page (right-click, “View Page Source”).

In my case, I’m getting an additional canonical tag generated just after the … element, which references the domain with the collection name, but without the page Slug.

For example:
<link rel="canonical" href="https://project.webflow.io/blogs"/>
Rather than:
<link rel="canonical" href="https://project.webflow.io/blogs/page-slug"/>

6 Likes

Are you sure you don’t have a canonical in your custom code as well?
Check site-wide and page-specific.

Other thing I’d check is whether you have a default locale set for your site under site settings, if not, some weird things happen for some people. Might be related, i.e. two separate mechanisms competing- the default auto-canonical, and a new localization-specific path canonical feature.

1 Like

Same problem here ! I’m getting a wrong additional canonical URL.
I just added the locals to my webflow project last friday when the feature got out so maybe it’s related ?

2 Likes

same problem here :roll_eyes:
I guess it’s because of the new localization feature? (I use only the free preview)

seo-wise its useful but should redirect to the full URL

1 Like

It’s definitely Webflow causing it. I spent hours debugging it and running tests to try and work around it. I even tried cloning one of the sites but experienced the same issue.

I imagine it’s likely connected to the localisation stuff, as others have suggested.

No reply from support as of yet.

Hello, same for me !
I have this default Canonical Tag on each of my articles :
<link href="https://www.example.com/blog" link rel="canonical"/>

Instead of <link href="https://www.example.com/blog/slug" rel="canonical" />

1 Like

Gaah. Well, self-help wins here. Must protect that SEO investment.

A few things you could try-

  • Disable auto canonicals, at least until this is fixed. You can manually re-add them to your most heavily trafficked pages
  • Or, remove them with script
  • Or, reverse proxy and remove them that way

Note solutions 1 and 2 would still show errors in tools like SEMrush or Ahrefs, but Google should be fine with both of them and they’re easy to implement.

Definitely don’t want that /blog/ one hanging around, that would essentially be telling google to unlist every single blog article you have.

Sorry I’m new on Webflow.
How can I “Disable auto canonicals” @memetican ?
Where in settings ?
Thank you !

1 Like

Can’t see how to disable auto-canonicals, I tried to empty the field where we can put the Global canonical tag URL but it didn’t delete the canonicals on my pages

1 Like

Solution 1 definetly not working, I managed to unable the auto canonicals and added manually on all my pages the good canonical but the one that was added before didn’t disappear. So the problem remain the same

Does this code respond to the second point ? :

<script>
// Immediately remove the first canonical tag
document.addEventListener('DOMContentLoaded', function () {
  // Find all canonical tags
  var canonicalTags = document.querySelectorAll('link[rel="canonical"]');

  // If there is more than one canonical tag, remove the first one
  if (canonicalTags.length > 1) {
    canonicalTags[0].parentNode.removeChild(canonicalTags[0]);
  }
});
</script>
2 Likes

looks like this works :star_struck:
its not shown correct in ahrefs but search console shows correct canonical :raised_hands:
thank you so much for your help @Serhat_Yildirim

This setting here in Romain’s screenshot.
When the Global canonical URL field is blank, Webflow doesn’t [didn’t] auto-generate canonical tags. It’s possible that’s changed with localization, but I’m not sure why that would be.

That looks good, I don’t have a site showing this problem to test it on. Keep in mind once the bug is fixed, this would be removing your main canonical since it would then become the first one.

as my dashboard is down again, i think wf rolls out again and the bug might be fixed later today

Note: As this uses clientside Javascript (e.g. runs via the browser after the page has initially loaded), any crawlers that don’t render clientside Javascript (which is most) will still pick up the canonical tag.

This seems to be mainly affecting WF projects that are quite new, e.g. in the past 30 days.

Hey, everybody!

I have the same problem with canonical tags.
Technical support does not answer.

I have an automatically generated without my consent canonical tag :

.

Instead of
I subscribed to localization, and got this error in Ahrefs - indexed pages are not indexed.

I finally got a answer from the support and they basically said that they identified the issue and they are working on it but no timeframe for the resolve.
The solution they gave me was a link to this post telling me to use the script from above ahaha

.

In fact I tried the script and tested it with my SEO expert and it seems that sometimes the script does work and sometimes not. But in the worth case if google search manager detect 2 different canonical it just consider there is NO Canonical which is better than identifying the wrong one.

I can’t believe Webflow would launch something with such a big bug!!! It’s making me reconsider using Webflow to be honest!

I’ve put the script in the custom code across the site, thank you @Serhat_Yildirim so much, life saver, i’m hoping this works well enough for Google.

Lets hope Webflow actually have people working on this issue.

I removed localisation, which i had hoped would remove this issue, but its still present in the code.

I’m beyond angry at Webflow right now!

Also very worrying that it’s been 2 days since this issue has been flagged and they haven’t fixed it!

1 Like

In my experience, SEO-related issues and features have always taken a backseat within Webflow.

What’s lousy, though, is if I hadn’t spotted the issue before launching my clients’ new sites (which are replacing old sites), their new site would have received a massive SEO hit, damaging our relationship with a new client.

This situation is especially tricky as I’m also working with an SEO company who aren’t keen on using the Webflow CMS anyway :grimacing:

If their support team has suggested using Javascript as a workaround, it shows a lack of knowledge about SEO and how crawlers work. It isn’t a solution.

On another note, I’ve created another post which asks for a Webflow Bugs Page, so that Webflow users can quickly look up any active bugs without wasting loads of time trying to figure out if it’s their project instance or a problem with Webflow itself: Webflow Bugs Page