Site not in Index: redirect error google search console (www to non-www)

Hey guys,

I’m finding myself in some kind of weird loop of issues - hope someone can help (Site not getting indexed by google…)

The loop:

  • non www domain is the google search console property
  • my domain hoster doesn’t allow a 2nd cname record so I had to switch to a www-domain as default
  • now google search console is not indexing the site because of “redirection error”
  • google suggested to manually use 301 redirect non-www to www - but webflow only 301-redirects paths
  • google is warning me not to create new search console property

Now the site is not indexed and the client is mad.
Anyone has an idea here?
Big thanks in advance!

What’s the domain?

  • When you have a default domain, the others automatically 301 to it, so if www is default, non-www will 301
  • If your DNS is limited and causing issues, switch to cloudflare’s free DNS. It supports cname flattening as well, if you want your non-www to be the default
  • Your GSC property should be a domain property, not a URL property
1 Like

Thanks for the help Micheal. Really appreciate it.

These are the DNS settings:

These are the SEO Webflow Settings:

In all-inkl (hosting provider) could be the issue I’ll switch.
Just a bit weird since I already done this often with other sites…

Everything looks perfect on your site settings.
It does look like you’re missing an A record in your DNS, you should have 2, but I think that’s primarily for load-balancing and failover.

I’d assume it’s the GSC setup.

One of the main things is to make certain you submit the correct URL for the sitemap. If you e.g. submit it as http: or without the www the sitemap itself will redirect and GCS sometimes will reject it.

1 Like

Hey Micheal,
I switched to cloudflare and added the 2nd A-record and it works!
Also removed the sitemap and just put it on auto generate, but I think the 2nd A-record was the solution here.

Big thanks - your next beer is on me :wink:

1 Like