Site down - "The page isn’t redirecting properly"

Our site is down today, after we updated the DNS to the recommended ones by Webflow.
Current DNS:

  • and

We have 2 green checks on Webflow. DNS are entered on NameCheap.

This is our current Webflow hosting status:

Current DNS on NameCheap:

Did we messed up something in the process?

Here is my site Read-Only: ****
(how to share your site Read-Only link)

Hi @francopd
Just want to check the obvious: did you publish to the custom domain after connecting the domain?

The CNAME record for usually would be pointed to @ depending on how you are wanting to configure, rather than portal.

I personally tend to use CloudFlare as a name server without using their proxy. I then use only CNAME records for @ and www pointed at

Thank you for your help. Yes it was published on the custom domain. Everything was working fine until we updated the DNS.

We used to have an ALIAS record on www pointing to Now we replaced it with the CNAME in order to get Webflow to connect, but everything broke. We tried to look into CloudFlare but it seemed overcomplicated (I might be wrong).

Ok, if you have published to both destinations on Webflow, then it is likely to be the DNS.

I found the settings page quite confusing for flattened domains. Try removing both A records and just setting two CNAME records, one with a value of @ and one with a value of www both pointing to and see if that works. It may take a while for the DNS to populate across ISPs.

Also worth checking that NameCheap support flattened domains for SSL. If not, you may have to do www

I just received a reply from the Webflow support team and we solved our issue (Cullan is the best!!). The DNS were correct, but we should have had the “www” site as default, not the root domain.

I want to paste the entire reply from the Support team here in case someone else has the same issue.

It looks like the DNS settings are configured properly – but it looks like you’ve set the root domain (the version of your domain without the www) as the default, which can cause unexpected behavior, such as loading issues in some geo-locations and problems with site crawling due to excessive redirects. Some DNS providers also do not support using SSL on the root domain.

For these reasons, we typically recommend that you set your default domain to the full domain (the www version). To do this, visit the Hosting tab of your project settings and hover over this domain in the list of custom domains. Then select the “make default” button that appears.

If you prefer to set the root domain as the default, this is possible, but requires a slightly different setup for your DNS records. You can reference this article from Webflow University for more information on setting the root domain as default and for providers that support this configuration: Setting the root domain as the default domain on SSL hosting


Glad you sorted it! Yes, I’ve never managed to get root domain working with A records, only CNAME.

We just got a reply from Support, by mistake we put the root domain as default instead of the “www”. Just changing that setting was enough to be back online! The Webflow support team was super-fast.
Thank you Max for your help as well, we’ll take a look into CloudFlare as you recommended.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.