Streaming live at 10am (PST)

Removing Unused Classes

Working on a project that originated from a duplicate of a previous site. Unable to get rid of styles from the first site. These are the steps I’ve gone through:

  1. I removed all elements using these classes, from all pages.
  2. deleted all interactions that may have used these classes
  3. deleted all symbols that may have used these classes
  4. duplicated the site and attempted “clean up”
  5. deleted ALL interactions and ALL symbols
  6. deleted individual pages, logged out, logged in
  7. deleted every page of the website, logged out, logged in

Even after all of this, with one blank homepage, the styles from the previously copied site still remain. I’m at a loss. Do I have to start every project from scratch to have a clean style sheet?

Steps 1-4 have worked for me in the past but no longer.

Share link:

@Port_of_Folio thank you so much for posting this!

I was trying to look into this issue as I haven’t been able to reproduce the behavior you’re describing, but your site which you referenced is no longer showing up. Could you please share a new Read-Only link of your site?

​Thanks in advance!

Sorry, I had changed the name after creating multiple copies of the site. Here is the latest:

Specifically trying to get rid of the “Country Color Code” styles and any other “Africa” related styles.


After messing around, I finally found the solution (which I’m not sure why it worked) but after deleting each element on each page to see if an element was holding these old styles, and no elements, symbols or interactions contained them… it wasn’t until I clicked on the 404 page and all 91 unused styles instantly appeared in the Style Manager “Clean Up” column. Something in the 404 page is holding onto older (previously duplicated site) styles.

I didn’t have any of the old elements on the 404 page. Just something about clicking on the page made them pop up as unused.

Tip for anyone out there with the same issue.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.