Streaming live at 10am (PST)

Having Issue to Clean Up and Remove Classes

Don’t know if this is a bug or if its me…but classes that I’ve used and are not used anymore on any element of my site…they aren’t cleared when i press “Clear up styles” in the Styles Manager. I crosschecked my pages and the specific classes aren’t used at all.

All of the specific styles had been part of a symbol, that I firstly unlocked and then deleted the elements the symbol consisted of.

I’ve had this problem numerous times now on different Webflow-projects.

Somebody got anything on this?

Does the symbol still appear in the assets tab > symbols? If it does, delete it and try cleaning up unused classes. If classes have subs or dependancies you often have to run cleanup twice. Also be sure that you have removed unused background images.

No, the symbol is gone. Haven’t used any bg images and there were no sub-classes.

I inserted the symbol, unlinked the symbol (i still appears in the asset tab), deleted the elements the symbol consisted of and then finallly deleted the symbol from the asset tab. Still the classes aren’t deleted. I won’t happen every time, but from time to time.

Now I’ve decided to still use the classes I’m currently talking about, but as I’ve said, this has happened before as well.

Hi @StevenP, thanks for your post. One thing I just want to confirm. After you deleted the symbol and the elements with classes in the symbol, did you try to clean the classes from the Style Manager, or did you expect the classes to be removed when deleting the symbol? The classes will not be removed, even if you delete the elements that were using the classes. You need to use the Styles Manager for that. If you have used the Styles Manager, and the classes do not get deleted, then that does sound like a bug, and we would have to reproduce that to confirm it.

Ocassionally, when a symbol is deleted, and very occasionally at that, the style used in the Symbol might still show as being used by a symbol. In that case, report that too us, and we can take a look.

Cheers, Dave

After deleting the symbol, I deleted the classes in the Style Manager. But they didn’t disappear. For now, I decided to use those classes anyway, but I’ll report back when/if I come across this problem again.


Thanks @StevenP, I will try to reproduce this as well :smile: Thanks again for the report, cheers, Dave :slight_smile:

1 Like

I’ve had this happen to me before but don’t ask me how I finally eliminated the class.

if a class is used in an interaction (direct or indirect targeting) it cannot be deleted. Even if you change the name, the original name persists to prevent the interaction from breaking (slightly buggy feeling). Is that possibly the culprit?

1 Like

I managed to have the classes deleted after i changed my mind again…:stuck_out_tongue:
These classes, from a nav scroll element, were cleared out of the Style Manager when i deleted an unused footer that had absolutely nothing to do with the nav scroll element …weird. But …It’s all good now! But I simply can’t understand it’s relation to the footer. I swear to God there were no classes in that Footer that had these Nav scroll classes in it.

@StevenP, when you run into this again there is a simple way to chase down the class or element:

1 Like

Nice one! I’ll definitely use that next time!


Ran into this problem again regarding some classes made for Navigation. My navigation was a symbol. I didn’t want the navigation so I wanted to delete it. This is how attempted to remove the navigation completely and its classes. I did these steps one page at the time:

  1. Unlink the Navigation-symbol
  2. Deleted the Navigation and it’s all classes and subclasses.

I repeated this for all 8 pages, still the classes won’t be cleaned in in the Style Manager. Very irritating.

And I made video to show that even after re-initating the classes to a Navbar widget again and then trying to erase them again, they simply won’t be erased.


Here’s the preview link:

EDIT: I re-installed the nav and its classes just for the cause.

Hi @StevenP, thanks for the detailed info. This sounds like a bug. I have moved this to bug status. We will investigate :slight_smile: Thanks a lot for the report. As soon as I have an update, will let you know :smile: Cheers, Dave

1 Like

Thanks Dave, glad you look into this! :slight_smile:

I’ve also discovered this bug. I output the pages and did a search for the culprit class and it only showed in the CSS. Clicking “Clean Up Styles” never worked on this class (which did appear in a Global Objects menu). Also, changing the name of the class still did not remove it - it still showed, but with the new name.

What is the status on this bug ?

If I create a symbol, give it a class, then delete the symbol, the class remains and can not be removed “Cleaned up”

Is there a workaround to detonating the unused class(es) from the UI ?

I’m having this issue as well. any updates on this?

Same issues here. Have a bunch of classes that don’t appear anywhere on my site anymore and I can’t get rid of them. Sometimes when this happens logging out and restarting seems to help but it may just be a matter of waiting as well.

@tubes, @Anna_Kelian, If you exit to your Webflow projects dashboard and then re-enter the project Webflow will allow you to delete the remainder of your unused classes.

I’ve tried that. Also logged out, cleared browser cache and restarted computer, and waited for days. They’re nowhere in my site, I’ve deleted all symbols and exported my site and searched for the classes in the html files. Nowhere to be found except in the CSS.