Streaming live at 10am (PST)

Redirect Loop with www subdomain being default


I’ve set up several sites with custom domains. All of them work the same way:

DNS is on AWS Route53, A records for the plain domain ( is pointing ti the two IP address that webflow provides, CNAME records for are posting to

All sites work except one where I get a redirect from to and from there to, resulting in a redirect loop.

I’ve already tried unpublishing and republishing the site, disconnecting the domains and “just waiting for 30 minutes hoping that it’s just a weird caching thing”

I’m at a loss what to do now.

Any ideas?

If I request I don’t get a redirect back to HTTP. Instead I get the HTML content that I’d expect.

But why doesn’t it work on

1 Like

Can you provide the actual domain? It is likely there is a configuration error, but without knowing which domain to look at, it is very difficult to help debug from our side.

The domain is but the issue has resolved by now. It seems like there were redirect responses being cached for a very long time. Maybe something to look into.

It could be any number of things… If you have default domain rules on your DNS provider it can cause these. I ran into issues caused by that a couple of times.