Root domain is redirecting to www and showing 404 page

I am not using the www subdomain nor SSL for the moment.

Right now is loading (why??) and a 404 page is being displayed.

I have a CNAME pointing www to so this should not be happening. What could be causing this misconfiguration?

The “Publishing” section of my site shows no errors and says everything is set up correctly.

Hey @brenton_strine Welcome to the forum!

I am able to access without any issues. However, is being redirected to

Most browsers use HTTPS by default now. So pointing your www subdomain with a CNAME directly to another domain may result in the browser enforcing HTTPS.

I would try adding the www subdomain to your project, and adding the following CNAME record instead:

You can leave the default as the root domain since you aren’t using SSL, and publish your project. See if that works.

Ok, I see what happened, it was working but just was not showing up for me due to caching issues and the bare domain redirect as you said.

I’m re-enabling SSL now, with according to instructions here Set root domain as default domain | Webflow University .

I had tried that before and it didn’t work, maybe it was a caching issue though. Will let it sit overnight and see if it resolves itself. So annoying to have to have so many hours of downtime before knowing if I’ve misconfigured it or if it was just caching.

1 Like

Update: waited overnight and I have the 404 now. I’ve never had so much trouble configuring a domain. Webflow really makes things unnecessarily complicated.

I’m not sure what to do next. Turn SSL off again and just not have that feature available?

If you want to use the root domain as default you will need to use a DNS provider that provides CNAME Flattening. Currently it looks like you are using A records on your root domain. If that is the case, you can only use the www as default.

You may need to move your nameservers over to somewhere like Cloudflare if you want to use the root as default.

Either way it is still best practice to add both the root and www to your project settings.

Let me know if you have any questions.

Oh, I didn’t realize from the instructions that I needed to remove the A names. (In fact, the website hid the instructions from me, now that I think of it. I never even had a chance to see the applicable instructions. I appreciate the attempt at “just in time” info, but in the end it blocked info I needed due to improperly thinking my DNS didn’t have the right feature.)

I will remove the A records, is there a complete document somewhere that shows the full config needed? Or if there isn’t one, could we make one here, for the sake of future googlers?

It’s mostly working now. What is still not working is that if you type in the www subdomain, it’s not redirecting as it should to the bare domain, and it’s landing on a 404 page. Still perplexed about that one.

At any rate, for future googleers: here’s the configuration needed!

For a website using SSL and a “naked domain” (no www subdomain)

DO NOT use the A records it tells you to use! Neither the SSL nor the non-SSL A names! They’ll mess everything up.

1 Like