Redirect from google is not working

This isn’t a Webflow specific issue but wondering if community can help me.
Short problem: - this is the new website that I just built for my client, and the new business name

  • this is resolving fine, no issues. - this is the old website & old business my client took over

  • we setup a permanent redirect on GoDaddy at the domain level.
  • If you just type that into a url bar, or click on it from an email link or something - it redirects fine
  • If you do a google search for “knit one quilt too” and click any of the indexed links, it will error out.

GoDaddy states this is because there is no longer a website connected to that domain. Which I get. Because Google is directing you to a cached website that no longer exists.

  • However, shouldn’t the domain redirect just override that?

Short help: What’s the solution to this.

Thank you.

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey Brad,

There is no such thing as a domain redirect- redirects are a feature of the HTTP protocol and therefore by definition they require a web server to receive the HTTP request and respond with a redirect header.

Some domain registrars or DNS providers have a mechanism that provides a simple HTTP redirect facility for domain names, but I’ve seen many of these redirect only the root page requests /, and nothing beneath- which sounds like the problem you’re facing.

First check the GoDaddy docs, there may be a way to configure this better. Make sure you’re using Fowarding only, and not the masking feature which will likely try to IFRAME your site.

However if you’re trying to redirect all traffic from to, the easy way is to configure both of them on your hosted website, and make one of them ( usually ) the primary domain for the site. Webflow will then effectively treat them as the same domain name.

Failing that, if you need more complex routing where some URLs go some places and others go to others, I’d recommend a more capable routing solution like CloudFlare’s Rules. You can keep your domain on GoDaddy and setup a free CloudFlare account for your nameservers, then setup rules that direct to the appropriate pages on your new site. The free account provides for 3 rules.

Thanks for the clarification on redirect.

I actually did your suggestion of adding a second domain in webflow, but it kept saying “not published”, and in the publishing it didn’t have an option of publishing to the second domain.

Sounds like you didn’t set a primary domain?
You won’t see a “not published” there because when a primary domain is set from Webflow’s perspective the sites are unified under one name.

Hi Mike,
This is what I see when I’ve added it.

I have the www. set as the default domain.
But as you can see the secondary domain just says “not published” and when I choose from the publishing area, it only shows the first domain.

That looks pretty buggy to me. I’d remove and re-add that domain, then re-publish and see if it attached properly.

if it’s still not working Webflow’s support would be able to look at it.

Thanks for your help.
Turns out, you need to unselect the default domain, then publish to all domains, then re-select the default domain.

For some reason, if you’ve already set a default domain, any that you add after won’t link to the publishing.

It’s all straightened out now, thank you!

Side note:

  • Will this eventually bump the old website ( off Google search results, since it’s being redirected to (even though Webflow is doing the redirecting)?

Thank you again for all your help!

Yes eventually. 301 redirects indicate a permanent new home for those pages, so google will update in the coming months.