Google Can't Index My Site Due To Redirect Error

Hi Webflow community,

Wondering if anyone can help.

I published my site using a custom domain and that all works fine but Google Search Console says the URL can’t be indexed due to a “Redirect Error”.

I’m not overly technical so I’m not sure if this is an issue with my Webflow settings or GoDaddy DNS settings. Any help would be greatly appreciated.


Hey Joe!

One tip I have is to check what URL you have set in Google’s search console. Do you still use the http version inside search console? Do you use the www version?

I found a guide that says:

  • Cause : Redirect errors are typically caused by one of the following:
  1. There was a redirect chain that was too long (use 3 max)

  2. There was a redirect loop (A points to B which points to A…)

  3. The redirect URL eventually exceeded the maximum length (this can be a problem when you’re redirecting within layered navigation and/or when adding query parameters)

  4. There was a bad or empty URL in the redirect chain

  • Fixing these errors : Review all of your redirects and ensure there is only a single redirect whenever possible. The Chrome Extension “Ayima” is great at detecting if a page has been redirected, where it redirects to, and the number of redirect hops present, which should help identify issues on a page-by-page basis.

Have a go at this and keep me posted :slight_smile:

Thanks RDaneel,

I installed the Ayima extension as you suggested and it confirmed that there are no redirects happening, so any issue with the redirect chain is surely a moot point…

Thanks again for your suggestions.


Thanks RDaneel, please see my response inline above. Also in answer to your question I’ve tried testing the http, https and www versions in Search Console and Google throws back the same error for all of them…

Hmm, I don’t have any good additional tips.

Maybe also try setting the www as the default?

Here’s some more discussing

They all suggest setting www as default due to some hoster not allowing non www to be set as root…

Thanks a million. Switching the default domain to www seems to have fixed it. Google can now index it :slight_smile:

1 Like

Glad it worked :slight_smile:
I’ll have a look at why this for some hoster

1 Like

UP? I have the same issue and I’d prefer to use my direct link without ‘www’ in front of it.

Thank you in advance,