Domain with www prefix not properly directing to root domain

I have set up my domain to use the bare domain (no www) and SSL. I have followed the instructions at
Set root domain as default domain | Webflow University wit an alias and CNAME set up.

However, as detailed in my other thread (Root domain is redirecting to www and showing 404 page - #7 by brenton_strine) the www subdomain is still incorrect. Webflow is not redirecting it to the bare domain and it is instead showing a 404 page.

See: ← works correct ← incorrect. Does not forward to bare domain, shows 404 page.

Hi, anyone have any ideas on this?

Hey @brenton_strine Sorry I missed your reply previously.

You will need to add both the root and www versions to your domain even if you are only using the root as your default. Follow these steps:

  1. Go to the publishing tab of your project settings
  2. Click Add a Custom Domain
  3. Enter your domain with the www (
  4. Click Add Domain
  5. Publish your project

Your www will now forward to your root domain.