Published site button navigating to wrong page

Hello Webflow’ers,

A button on my published site is going to the wrong page. (It’s the first one, next to Ironeye.) However, when I’m in the editor and even in read-only mode it goes to the correct page. This occurs only on the published site. I’ve tried making a copy of the correct page and linking the button to it; I’ve even tried creating a new button, but the button still goes to the same wrong page. (It should go to Ironeye but instead goes to Stella’s Bakery.) Anyone know how to resolve this?

Thank you so much in advance!


Here is my site Read-Only: Webflow - Lillian Grace King Portfolio
Here is my published site: https://www.lilliangraceking.com/

Hi @lilliangking, thanks for your post.

When a page link redirects to another page on the site, one of the first things I like to check is if there are any 301 redirects setup on the site that is being hosted.

You can do that by going to site settings, then go to the Hosting tab and scroll down to the redirects section and look for a page redirect from the Ironeye page to the Stellas bakery page.

Learn more about redirects here: 301 redirects | Webflow University

If there is redirect there, then delete that and then republish the site to disable that redirect.

If you have no redirect there, let me know and I am happy to assist further.

.cyberdave

Hi @cyberdave! Thanks for your quick response.

I did as you suggested and there were two redirects, so I deleted them both and republished the site. However, the problem still persists. So definitely would love to take up on your offer of additional assistance!

Hi @lilliangking,

Thanks for your reply, one thing I noticed is that the last time the site was published was 3 hours ago, is that after you made the changes or before? Could you republish the site once?

Now that the redirects are removed, if the issue persists, it is good to check the hosting tab of project settings and make sure both custom domains are set, there are two in most cases:

example.com
www.example.com

Where example.com is your domain name. Both domains should be added to the custom domains section of the hosting tab.

Then check/update the DNS records on the root domain(s) to point the DNS records at the correct servers and domains are all connected.

The root domain (without www, like example.com) should have these two A-records:

Type: A
Name: @
Value: 75.2.70.75

Type: A
Name: @
Value: 99.83.190.102

The WWW subdomain should have a CNAME record and should use the following values:

Type: CNAME
Name: WWW
Value: proxy-ssl.webflow.com

After DNS changes are made, got to the hosting tab of project settings, set the
WWW domain as the default domain
and then Publish your project.

Another way to check this is to publish the webflow.io staging domain for your project and then view the site on the staging domain, if the link works, then there is probably some domain issue as mentioned above where not all domains are added or published.

Let me know in case of any questions, if the issue still persist after checking the domains, I will be happy to check further.