Streaming live at 10am (PST)

Site not publishing, despite "success" message

Hey - so, I pushed our site live the other day and now whenever I try to re-publish the site it doesn’t seem to overwrite the previous version. I’m publishing to both the Webflow test server ( and our live site ( The staged site reflects the updates, whereas the other does not. Webflow isn’t returning any errors when I publish and the hosting page shows all green lights (as shown in screenshot). To my knowledge, I haven’t changed anything with the DNS or anything else that would affect this (as shown in the second screenshot from Google Domains); but, admittedly, this is outside of my area of expertise. Reeeeally need to get this resolved ASAP, so if someone could point me in a direction to explore it would be greatly appreciated, as I’m officially out of options.

Here is my site Read-Only: LINK

Not sure if this is related, but when I make ‘’ the default (instead of ‘’) I get an error saying “too many redirects” - which I’ve seen numerous posts about, but have yet to find a solution that seems relevant to what I’m experiencing.

Hi Devin,

Cool site!

I have heard of this before and it’s not related to Webflow specifically. Unless you have added any redirects that could cause a loop.

Alternatively have you tried clearing your website browser cache? Might sound trivial but it could be todo with corrupt site cookies. And because you might have been trouble shooting it has stored the corrupt files.

If both of these haven’t fixed it. I’ll have a look later on and try and find a fix for you!

Try the cache, it could do the trick…

Best regards,

Steve | 3SIX5 Digital

Thanks Steve, the suggestions are much appreciated! Unfortunately, I’ve tried clearing the cache/cookies (now multiple times) and have tried testing on multiple browsers/devices with the same result. I’m also not seeing anything under the 301 section that would indicate a problem, so once again I’m stumped. Any digging you can do on your end would be amazing, if you have the time to help a brother out.

I just went to and noticed that it’s returning the error “clientTransferProhibited” under “Domain Status”. I don’t have any experience with this error, but it would seem to be a likely culprit. Contacting Google to see what’s up - will report back with my findings.

All that means is the domain is locked. That has nothing to do with DNS. It does stop you from changing name servers and contact records as well as initiating transfers. You can unlock / lock your domain anytime at your registrar.

A visit to produced 19 redirects. Ensure you have no domain redirects nor site host redirects.

I also checked Google’s public DNS servers to see what your settings were and they are correct.


I would unpublish the custom domain and then republish again. See if that resolves the issue. If it does not contact Webflow support for assistance.

Thanks Jeff, I’ll give it a shot. Is there somewhere other than the ‘Hosting’ tab of Webflow that I could look into why it’s redirecting? There’s nothing showing under the 301 section, so I’m a bit confused as to why that would be.

It’s a 301 redirect. You have SSL enabled right? Make sure you do since you are using the SSL records for SSL hosting. It could be also be a bug. That’s why I asked for unpublish / republish to see it persists.

For the love of… could it really have been as simple as restarting the editor?!! This whole time it was publishing to ‘’ instead of ‘’, as I originally had the former set as the default. I still don’t fully understand what the difference is, or why Webflow wouldn’t publish to BOTH to circumvent this pesky issue; but, the good news is, it seems to be working!

1 Like