Streaming live at 10am (PST)

Problem with fonts on site hosted outside of Webflow

Hello folks,

I changed the fonts of my website and everything worked perfectly. I changed the name of the project and since then, the custom fonts aren’t loading. I don’t think that it’s because of that, but why does this happen immediately?
Now, when I upload the whole package to my ftp server, the custom fonts disappear and arial is the normal font.
Please give me a tip, we want to go live in 1 day! :frowning:

Thank you !!

I also tried the fix to upload the other types of the font, but it doesn’t affect anything. -.- is the url.

Hi @Tobias_Hall

Thanks for posting this, this definitely sounds like odd behavior.

I took a look at in Chrome, Safari, Firefox and IE 11. All seem to be rendering the font as expected.

What machine and browser / browser version are you seeing this issue on? Can you please send me screenshots of the behavior you’re describing? You can use this tool:

Can you also please try the following:
(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off:
(2) If the problem persists, please take a screenshot of your Console and send it to me:

Thanks in advance!

I use Chrome 59 on Mac OS X 10

but still have the problem:

@Tobias_Hall thanks for replying so quickly. That is definitely odd.

Are those screenshots in incognito mode? If not can you please try viewing the site in an incognito window with all browser extensions disabled.

​Thanks in advance, and I’m standing by for your reply.



I found out, that the problem with the fonts only happen, if you type “” instead of ! I hope that can help to fix that issue?!

Best regards

1 Like

Hi @Tobias_Hall, one thing I noticed, is that the site is not pointing at Webflow servers:

I would check that your fonts are loading correctly from the external server and that all font files were uploaded from the fonts folder that gets created at export:

Also,you can tell if there is any issue with the font, or after export, by loading the exported index.html file that is generated, in Safari from the hard drive. The fonts should show correctly.

Webflow does not provide support for external server hosting, however the exports should be working fine on export. If there is any issue with the unmodified, exported site, contact to us on the support desk:

I hope this helps!

Hello @cyberdave,

I always download the whole export zip and upload it to my ftp server. So this can’t be the problem…
Any other ideas?

Hi @Tobias_Hall, thanks a couple of quick questions.

Before you ftp, if you open the index.html file in Safari, do the fonts look correct?

I am checking an export to see how that looks for me. I will get back to you as soon as I have a result from the local export.

Thanks in advance!

Hello Dave,

I found out, that the problem only appears, when you miss the “www.” before the url.
On everything works fine ! So what’s the problem ???

Best regards

on research I found this:

How can I solve the problem in webflow?

Anyone have some ideas ?

Any ideas cyberdave? Didn’t hear from you in a while…

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.