Custom Fonts not working in Chrome all of a sudden

I updated my site a few minutes ago and all of the fonts are defaulting to random ones in Chrome browser on desktop. Chrome on mobile looks fine and I also tried Safari on desktop and works fine. It is happening for other viewers as well, not just my computer.

Correct on Safari and Chrome mobile:

Incorrect on Chrome desktop:

Now they aren’t working in the Webflow Designer! What’s going on?

Seems ok to me. Do note it may take a while for fonts to load if you are on a slow internet connection

Still was not working even when I tried in different places with different internet connections. It had been working perfectly for months and now all of a sudden it stopped. I even uninstalled and reinstalled all the custom fonts in the site settings, but still nothing. The only solution I knew to do was to upload a different custom font and replace the old one with the new one all over the site.

Wah wah.

Hi @kbarrett

Thanks for posting about this.

Did uploading the the new font resolve the issue for you?

From this end it looks like the custom fonts are working as expected.

​Thanks in advance, and I’m standing by for your reply.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.